[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20220531170050.ue6hizqjugz2g4wl@offworld>
Date: Tue, 31 May 2022 10:00:50 -0700
From: Davidlohr Bueso <dave@...olabs.net>
To: "ira.weiny@...el.com" <ira.weiny@...el.com>
Cc: Dan Williams <dan.j.williams@...el.com>,
Bjorn Helgaas <bhelgaas@...gle.com>,
Jonathan Cameron <Jonathan.Cameron@...wei.com>,
Alison Schofield <alison.schofield@...el.com>,
Vishal Verma <vishal.l.verma@...el.com>,
Dave Jiang <dave.jiang@...el.com>,
Ben Widawsky <ben@...dawsk.net>, linux-kernel@...r.kernel.org,
linux-cxl@...r.kernel.org, linux-pci@...r.kernel.org,
a.manzanares@...sung.com
Subject: Re: [PATCH v9 2/9] PCI: Replace magic constant for PCI Sig Vendor ID
On Tue, 31 May 2022, ira.weiny@...el.com wrote:
>From: Ira Weiny <ira.weiny@...el.com>
>
>Replace the magic value in pci_bus_crs_vendor_id() with
>PCI_VENDOR_ID_PCI_SIG.
>
>Reviewed-by: Dan Williams <dan.j.williams@...el.com>
>Suggested-by: Bjorn Helgaas <bhelgaas@...gle.com>
>Acked-by: Bjorn Helgaas <bhelgaas@...gle.com>
>Signed-off-by: Ira Weiny <ira.weiny@...el.com>
Reviewed-by: Davidlohr Bueso <dave@...olabs.net>
>---
>Changes from V6
> Simplify commit message
>---
> drivers/pci/probe.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
>diff --git a/drivers/pci/probe.c b/drivers/pci/probe.c
>index 17a969942d37..6280e780a48c 100644
>--- a/drivers/pci/probe.c
>+++ b/drivers/pci/probe.c
>@@ -2312,7 +2312,7 @@ EXPORT_SYMBOL(pci_alloc_dev);
>
> static bool pci_bus_crs_vendor_id(u32 l)
> {
>- return (l & 0xffff) == 0x0001;
>+ return (l & 0xffff) == PCI_VENDOR_ID_PCI_SIG;
> }
>
> static bool pci_bus_wait_crs(struct pci_bus *bus, int devfn, u32 *l,
>
>--
>2.35.1
>
Powered by blists - more mailing lists