[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <59e0ae93-c7b-2087-75f8-4da0de918250@linux.intel.com>
Date: Tue, 7 Jun 2022 16:21:00 +0300 (EEST)
From: Ilpo Järvinen <ilpo.jarvinen@...ux.intel.com>
To: Jiri Slaby <jslaby@...e.cz>
cc: Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
linux-serial <linux-serial@...r.kernel.org>,
LKML <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH 03/36] tty/vt: consolemap: define UNI_* macros for
constants
On Tue, 7 Jun 2022, Jiri Slaby wrote:
> The code uses constants for sizes of dictionary substructures on many
> places. Define 3 macros and use them in the code, so that loop bounds,
> local variables and the dictionary always match. (And the loop bounds
> are obvious now too.)
>
> Signed-off-by: Jiri Slaby <jslaby@...e.cz>
Reviewed-by: Ilpo Järvinen <ilpo.jarvinen@...ux.intel.com>
> - for (k = 0; k < 64; k++) {
> + for (k = 0; k < UNI_ROW_GLYPHS; k++) {
> glyph = p2[k];
> if (glyph >= 0 && glyph < MAX_GLYPH
> && q[glyph] < 32)
Probably unrelated to this change but what's that < 32? It seems to appear
twice related to the inverse mapping (and you didn't end up naming it).
--
i.
Powered by blists - more mailing lists