[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <87pmjdyp62.fsf@intel.com>
Date: Mon, 13 Jun 2022 10:53:57 +0300
From: Jani Nikula <jani.nikula@...ux.intel.com>
To: José Expósito <jose.exposito89@...il.com>,
javierm@...hat.com
Cc: davidgow@...gle.com, airlied@...ux.ie, dlatypov@...gle.com,
linux-kernel@...r.kernel.org, dri-devel@...ts.freedesktop.org,
tzimmermann@...e.de,
José Expósito <jose.exposito89@...il.com>,
kunit-dev@...glegroups.com
Subject: Re: [PATCH v2 1/3] drm/rect: Add DRM_RECT_INIT() macro
On Sun, 12 Jun 2022, José Expósito <jose.exposito89@...il.com> wrote:
> Add a helper macro to initialize a rectangle from x, y, width and
> height information.
>
> Signed-off-by: José Expósito <jose.exposito89@...il.com>
> ---
> include/drm/drm_rect.h | 12 ++++++++++++
> 1 file changed, 12 insertions(+)
>
> diff --git a/include/drm/drm_rect.h b/include/drm/drm_rect.h
> index 6f6e19bd4dac..945696323c69 100644
> --- a/include/drm/drm_rect.h
> +++ b/include/drm/drm_rect.h
> @@ -47,6 +47,18 @@ struct drm_rect {
> int x1, y1, x2, y2;
> };
>
> +/**
> + * DRM_RECT_INIT - initialize a rectangle from x/y/w/h
> + * @x: x coordinate
> + * @y: y coordinate
> + * @w: width
> + * @h: height
> + *
> + * RETURNS:
> + * A new rectangle of the specified size.
> + */
> +#define DRM_RECT_INIT(x, y, w, h) { (x), (y), (x) + (w), (y) + (h) }
Please use designated initializers.
It might help type safety if it also contained a (struct drm_rect) cast.
BR,
Jani.
> +
> /**
> * DRM_RECT_FMT - printf string for &struct drm_rect
> */
--
Jani Nikula, Intel Open Source Graphics Center
Powered by blists - more mailing lists