lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Mon, 13 Jun 2022 14:37:19 +0200
From:   AngeloGioacchino Del Regno 
        <angelogioacchino.delregno@...labora.com>
To:     Tinghan Shen <tinghan.shen@...iatek.com>,
        Rob Herring <robh+dt@...nel.org>,
        Krzysztof Kozlowski <krzysztof.kozlowski+dt@...aro.org>,
        Matthias Brugger <matthias.bgg@...il.com>,
        Mark Brown <broonie@...nel.org>,
        YC Hung <yc.hung@...iatek.com>,
        Curtis Malainey <cujomalainey@...omium.org>,
        Allen-KH Cheng <allen-kh.cheng@...iatek.com>
Cc:     devicetree@...r.kernel.org, linux-arm-kernel@...ts.infradead.org,
        linux-mediatek@...ts.infradead.org, linux-kernel@...r.kernel.org,
        Project_Global_Chrome_Upstream_Group@...iatek.com
Subject: Re: [PATCH v2 2/3] firmware: mediatek: Use meaningful names for mbox

Il 09/06/22 10:31, Tinghan Shen ha scritto:
> Rename mbox according to action instead of 'mbox0' and 'mbox1'
> 
> Signed-off-by: Tinghan Shen <tinghan.shen@...iatek.com>
> ---
>   drivers/firmware/mtk-adsp-ipc.c | 6 +++++-
>   1 file changed, 5 insertions(+), 1 deletion(-)
> 
> diff --git a/drivers/firmware/mtk-adsp-ipc.c b/drivers/firmware/mtk-adsp-ipc.c
> index cb255a99170c..3de94765d659 100644
> --- a/drivers/firmware/mtk-adsp-ipc.c
> +++ b/drivers/firmware/mtk-adsp-ipc.c
> @@ -83,7 +83,11 @@ static int mtk_adsp_ipc_probe(struct platform_device *pdev)
>   		return -ENOMEM;
>   
>   	for (i = 0; i < MTK_ADSP_MBOX_NUM; i++) {
> -		chan_name = kasprintf(GFP_KERNEL, "mbox%d", i);
> +		if (i < MTK_ADSP_MBOX_NUM / 2)
> +			chan_name = kasprintf(GFP_KERNEL, "rep");
> +		else
> +			chan_name = kasprintf(GFP_KERNEL, "req");
> +
>   		if (!chan_name) {
>   			ret = -ENOMEM;
>   			goto out;

At this point, just call them "reply" and "request", as that simply provides a
perfectly clear explanation.

Besides, I'm sorry but I really don't like this code, it's really too much
fragile and will have to be changed entirely if a third mbox is introduced.

I can suggest a cooler way:

static const char * const adsp_mbox_ch_names[MTK_ADSP_MBOX_NUM] = { "rep", "req" };

for (i = 0; i < ARRAY_SIZE(adsp_mbox_ch_names); i++) {
	/* we can delete chan_name and also avoid a kfree if we do... */

	.... code ....

	adsp_chan->ch = mbox_request_channel_byname(cl, adsp_mbox_ch_names[i]);

	... etc etc ...
}

Cheers,
Angelo

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ