[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20220620060127.GA10297@lst.de>
Date: Mon, 20 Jun 2022 08:01:27 +0200
From: Christoph Hellwig <hch@....de>
To: Heiko Stuebner <heiko@...ech.de>
Cc: palmer@...belt.com, paul.walmsley@...ive.com,
linux-riscv@...ts.infradead.org, linux-kernel@...r.kernel.org,
wefu@...hat.com, guoren@...nel.org, cmuellner@...ux.com,
philipp.tomsich@...ll.eu, hch@....de, samuel@...lland.org,
atishp@...shpatra.org, anup@...infault.org, mick@....forth.gr,
robh+dt@...nel.org, krzk+dt@...nel.org, devicetree@...r.kernel.org,
drew@...gleboard.org, rdunlap@...radead.org
Subject: Re: [PATCH 1/4] of: also handle dma-noncoherent in
of_dma_is_coherent()
On Sun, Jun 19, 2022 at 10:32:09PM +0200, Heiko Stuebner wrote:
> bool of_dma_is_coherent(struct device_node *np)
> {
> struct device_node *node;
> + bool ret = false;
I'd rename this to coherent or is_coherent.
>
> if (IS_ENABLED(CONFIG_OF_DMA_DEFAULT_COHERENT))
> - return true;
> + ret = true;
And then do this at initialization time:
bool is_coherent = IS_ENABLED(CONFIG_OF_DMA_DEFAULT_COHERENT);
but otherwise this looks good to me.
Powered by blists - more mailing lists