lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 21 Jun 2022 12:02:14 +0200
From:   Thomas Zimmermann <tzimmermann@...e.de>
To:     David Gow <davidgow@...gle.com>,
        José Expósito <jose.exposito89@...il.com>
Cc:     dri-devel@...ts.freedesktop.org, magalilemes00@...il.com,
        David Airlie <airlied@...ux.ie>,
        Maíra Canal <maira.canal@....br>,
        Daniel Latypov <dlatypov@...gle.com>,
        Javier Martinez Canillas <javierm@...hat.com>,
        Linux Kernel Mailing List <linux-kernel@...r.kernel.org>,
        Jani Nikula <jani.nikula@...el.com>, tales.aparecida@...il.com,
        Isabella Basso <isabbasso@...eup.net>,
        KUnit Development <kunit-dev@...glegroups.com>
Subject: Re: [PATCH v4 1/3] drm/rect: Add DRM_RECT_INIT() macro

Hi

Am 21.06.22 um 11:38 schrieb David Gow:
> On Tue, Jun 21, 2022 at 12:06 AM José Expósito
> <jose.exposito89@...il.com> wrote:
>>
>> Add a helper macro to initialize a rectangle from x, y, width and
>> height information.
>>
>> Reviewed-by: Jani Nikula <jani.nikula@...el.com>
>> Acked-by: Thomas Zimmermann <tzimmermann@...e.de>
>> Signed-off-by: José Expósito <jose.exposito89@...il.com>
>> ---
> 
> This looks good to me, though I have one minor concern about the macro
> name. (But if it's okay with the DRM folks, which it seems to be, I
> won't object.)
> 
> Either way,
> Reviewed-by: David Gow <davidgow@...gle.com>
> 
>>   include/drm/drm_rect.h | 16 ++++++++++++++++
>>   1 file changed, 16 insertions(+)
>>
>> diff --git a/include/drm/drm_rect.h b/include/drm/drm_rect.h
>> index 6f6e19bd4dac..e8d94fca2703 100644
>> --- a/include/drm/drm_rect.h
>> +++ b/include/drm/drm_rect.h
>> @@ -47,6 +47,22 @@ struct drm_rect {
>>          int x1, y1, x2, y2;
>>   };
>>
>> +/**
>> + * DRM_RECT_INIT - initialize a rectangle from x/y/w/h
>> + * @x: x coordinate
>> + * @y: y coordinate
>> + * @w: width
>> + * @h: height
>> + *
>> + * RETURNS:
>> + * A new rectangle of the specified size.
>> + */
>> +#define DRM_RECT_INIT(x, y, w, h) ((struct drm_rect){ \
>> +               .x1 = (x), \
>> +               .y1 = (y), \
>> +               .x2 = (x) + (w), \
>> +               .y2 = (y) + (h) })
>> +
> 
> My only slight concern here is that it might be a little bit confusing
> that a macro called DRM_RECT_INIT() accepts x/y/w/h, whereas the
> actual struct drm_rect is x1/y1/x2/y2. If the macro were called
> something like DRM_RECT_INIT_FROM_XYWH() or similar.

The existing drm_rect_init() function uses xywh arguments. So the 
current name is consistent with existing practice. I don't think we 
refer to x2,y2 much, if ever.

Best regards
Thomas

> 
> 
>>   /**
>>    * DRM_RECT_FMT - printf string for &struct drm_rect
>>    */
>> --
>> 2.25.1
>>

-- 
Thomas Zimmermann
Graphics Driver Developer
SUSE Software Solutions Germany GmbH
Maxfeldstr. 5, 90409 Nürnberg, Germany
(HRB 36809, AG Nürnberg)
Geschäftsführer: Ivo Totev

Download attachment "OpenPGP_signature" of type "application/pgp-signature" (841 bytes)

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ