[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <YrQLY7WzgXPM/LqJ@FVFYT0MHHV2J.usts.net>
Date: Thu, 23 Jun 2022 14:42:43 +0800
From: Muchun Song <songmuchun@...edance.com>
To: Miaohe Lin <linmiaohe@...wei.com>
Cc: akpm@...ux-foundation.org, shy828301@...il.com,
willy@...radead.org, zokeefe@...gle.com, linux-mm@...ck.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH 04/16] mm/huge_memory: use helper touch_pud in
huge_pud_set_accessed
On Thu, Jun 23, 2022 at 01:06:15AM +0800, Miaohe Lin wrote:
> Use helper touch_pud to set pud accessed to simplify the code and improve
> the readability. No functional change intended.
>
> Signed-off-by: Miaohe Lin <linmiaohe@...wei.com>
> ---
> mm/huge_memory.c | 14 ++++----------
> 1 file changed, 4 insertions(+), 10 deletions(-)
>
> diff --git a/mm/huge_memory.c b/mm/huge_memory.c
> index a26580da8011..a0c0e4bf9c1e 100644
> --- a/mm/huge_memory.c
> +++ b/mm/huge_memory.c
> @@ -1281,21 +1281,15 @@ int copy_huge_pud(struct mm_struct *dst_mm, struct mm_struct *src_mm,
>
> void huge_pud_set_accessed(struct vm_fault *vmf, pud_t orig_pud)
> {
> - pud_t entry;
> - unsigned long haddr;
> - bool write = vmf->flags & FAULT_FLAG_WRITE;
> + int flags = 0;
>
> vmf->ptl = pud_lock(vmf->vma->vm_mm, vmf->pud);
> if (unlikely(!pud_same(*vmf->pud, orig_pud)))
> goto unlock;
>
> - entry = pud_mkyoung(orig_pud);
> - if (write)
> - entry = pud_mkdirty(entry);
> - haddr = vmf->address & HPAGE_PUD_MASK;
> - if (pudp_set_access_flags(vmf->vma, haddr, vmf->pud, entry, write))
> - update_mmu_cache_pud(vmf->vma, vmf->address, vmf->pud);
> -
> + if (vmf->flags & FAULT_FLAG_WRITE)
> + flags = FOLL_WRITE;
FOLL_* flags are used for follow_page(). But huge_pud_set_accessed() is used in mm fault
path. It is a little weird to me to use FOLL_WRITE here. I suggest replace the last
parameter of touch_pud() to "bool writable", then passing "vmf->flags & FAULT_FLAG_WRITE"
to it instead of converting from FAULT_FLAG* flag to FOLL* flag.
Thanks.
> + touch_pud(vmf->vma, vmf->address, vmf->pud, flags);
> unlock:
> spin_unlock(vmf->ptl);
> }
> --
> 2.23.0
>
>
Powered by blists - more mailing lists