[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <50badb0b-0cac-d935-02bf-f05403f6d765@gmail.com>
Date: Fri, 24 Jun 2022 20:01:41 +0200
From: Philipp Hortmann <philipp.g.hortmann@...il.com>
To: Chang Yu <marcus.yu.56@...il.com>, Larry.Finger@...inger.net,
phil@...lpotter.co.uk, gregkh@...uxfoundation.org
Cc: linux-staging@...ts.linux.dev, linux-kernel@...r.kernel.org
Subject: Re: [PATCH v4] staging: r8188eu: core/rtw_recv.c: clean up nested if
statements
On 6/24/22 16:45, Chang Yu wrote:
> Combine two nested if statements into a single one to fix indentation
> issue and improve readability, as suggested by checkpatch.pl
>
> Signed-off-by: Chang Yu <marcus.yu.56@...il.com>
> ---
> Changes in v4:
> - Added missing change log and resend
>
> Changes in v3:
> - Modified subject and description to be more descriptive
>
> Changes in v2:
> - Added a pair of parentheses to make operator precedence explicit
>
>
> drivers/staging/r8188eu/core/rtw_recv.c | 6 ++----
> 1 file changed, 2 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/staging/r8188eu/core/rtw_recv.c b/drivers/staging/r8188eu/core/rtw_recv.c
> index 6564e82ddd66..020bc212532f 100644
> --- a/drivers/staging/r8188eu/core/rtw_recv.c
> +++ b/drivers/staging/r8188eu/core/rtw_recv.c
> @@ -166,10 +166,8 @@ int rtw_free_recvframe(struct recv_frame *precvframe, struct __queue *pfree_recv
>
> list_add_tail(&precvframe->list, get_list_head(pfree_recv_queue));
>
> - if (padapter) {
> - if (pfree_recv_queue == &precvpriv->free_recv_queue)
> - precvpriv->free_recvframe_cnt++;
> - }
> + if (padapter && (pfree_recv_queue == &precvpriv->free_recv_queue))
> + precvpriv->free_recvframe_cnt++;
>
> spin_unlock_bh(&pfree_recv_queue->lock);
>
Tested-by: Philipp Hortmann <philipp.g.hortmann@...il.com> # Edimax N150
Powered by blists - more mailing lists