lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 29 Jun 2022 10:04:34 +0200
From:   Jacopo Mondi <jacopo@...ndi.org>
To:     Tommaso Merciai <tommaso.merciai@...rulasolutions.com>
Cc:     linuxfancy@...glegroups.com, linux-amarula@...rulasolutions.com,
        quentin.schulz@...obroma-systems.com,
        Daniel Scally <djrscally@...il.com>,
        Mauro Carvalho Chehab <mchehab@...nel.org>,
        linux-media@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH v2 5/7] media: ov5693: rename ov5693_check_hwcfg into
 ov5693_get_hwcfg

On Mon, Jun 27, 2022 at 05:04:51PM +0200, Tommaso Merciai wrote:
> Function ov5693_check_hwcfg don't only check the hw configuration but

s/don't/doesn't/ ?

> also get the hw configuration. Is better better to rename this into ov5693_get_hwcfg

The concept of "getting" the hw configuration vs "checking" it is
debatable. The function does many other things as far as I can tell.

However, this is also a little arbitrary but I guess it doesn't hurt ?

Reviewed-by: Jacopo Mondi <jacopo@...ndi.org>

Thanks
  j

>
> Signed-off-by: Tommaso Merciai <tommaso.merciai@...rulasolutions.com>
> ---
>  drivers/media/i2c/ov5693.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/media/i2c/ov5693.c b/drivers/media/i2c/ov5693.c
> index d5a934ace597..273caef467fe 100644
> --- a/drivers/media/i2c/ov5693.c
> +++ b/drivers/media/i2c/ov5693.c
> @@ -1339,7 +1339,7 @@ static int ov5693_get_regulators(struct ov5693_device *ov5693)
>  				       ov5693->supplies);
>  }
>
> -static int ov5693_check_hwcfg(struct ov5693_device *ov5693)
> +static int ov5693_get_hwcfg(struct ov5693_device *ov5693)
>  {
>  	struct fwnode_handle *fwnode = dev_fwnode(ov5693->dev);
>  	struct v4l2_fwnode_endpoint bus_cfg = {
> @@ -1431,7 +1431,7 @@ static int ov5693_probe(struct i2c_client *client)
>  	ov5693->client = client;
>  	ov5693->dev = &client->dev;
>
> -	ret = ov5693_check_hwcfg(ov5693);
> +	ret = ov5693_get_hwcfg(ov5693);
>  	if (ret)
>  		return ret;
>
> --
> 2.25.1
>

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ