lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Thu, 30 Jun 2022 12:17:42 +0200
From:   Andy Shevchenko <andy.shevchenko@...il.com>
To:     Ilpo Järvinen <ilpo.jarvinen@...ux.intel.com>
Cc:     Andy Shevchenko <andriy.shevchenko@...ux.intel.com>,
        Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
        Jiri Slaby <jirislaby@...nel.org>,
        "open list:SERIAL DRIVERS" <linux-serial@...r.kernel.org>,
        Linux Kernel Mailing List <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH 1/1] 8250_dwlib: Convert bitops to newer form

On Thu, Jun 30, 2022 at 12:08 PM Ilpo Järvinen
<ilpo.jarvinen@...ux.intel.com> wrote:
>
> Instead of open-coding, use BIT(), GENMASK(), and FIELD_GET() helpers.

FIELD_GET() requires bitfield.h to be included. Is this the case already?
If so,
Reviewed-by: Andy Shevchenko <andy.shevchenko@...il.com>

> Signed-off-by: Ilpo Järvinen <ilpo.jarvinen@...ux.intel.com>
> ---
>  drivers/tty/serial/8250/8250_dwlib.c | 26 +++++++++++++-------------
>  1 file changed, 13 insertions(+), 13 deletions(-)
>
> diff --git a/drivers/tty/serial/8250/8250_dwlib.c b/drivers/tty/serial/8250/8250_dwlib.c
> index da330ef46446..a8bbed74ea70 100644
> --- a/drivers/tty/serial/8250/8250_dwlib.c
> +++ b/drivers/tty/serial/8250/8250_dwlib.c
> @@ -46,21 +46,21 @@
>  #define DW_UART_LCR_EXT_TRANSMIT_MODE  BIT(3)
>
>  /* Component Parameter Register bits */
> -#define DW_UART_CPR_ABP_DATA_WIDTH     (3 << 0)
> -#define DW_UART_CPR_AFCE_MODE          (1 << 4)
> -#define DW_UART_CPR_THRE_MODE          (1 << 5)
> -#define DW_UART_CPR_SIR_MODE           (1 << 6)
> -#define DW_UART_CPR_SIR_LP_MODE                (1 << 7)
> -#define DW_UART_CPR_ADDITIONAL_FEATURES        (1 << 8)
> -#define DW_UART_CPR_FIFO_ACCESS                (1 << 9)
> -#define DW_UART_CPR_FIFO_STAT          (1 << 10)
> -#define DW_UART_CPR_SHADOW             (1 << 11)
> -#define DW_UART_CPR_ENCODED_PARMS      (1 << 12)
> -#define DW_UART_CPR_DMA_EXTRA          (1 << 13)
> -#define DW_UART_CPR_FIFO_MODE          (0xff << 16)
> +#define DW_UART_CPR_ABP_DATA_WIDTH     GENMASK(1, 0)
> +#define DW_UART_CPR_AFCE_MODE          BIT(4)
> +#define DW_UART_CPR_THRE_MODE          BIT(5)
> +#define DW_UART_CPR_SIR_MODE           BIT(6)
> +#define DW_UART_CPR_SIR_LP_MODE                BIT(7)
> +#define DW_UART_CPR_ADDITIONAL_FEATURES        BIT(8)
> +#define DW_UART_CPR_FIFO_ACCESS                BIT(9)
> +#define DW_UART_CPR_FIFO_STAT          BIT(10)
> +#define DW_UART_CPR_SHADOW             BIT(11)
> +#define DW_UART_CPR_ENCODED_PARMS      BIT(12)
> +#define DW_UART_CPR_DMA_EXTRA          BIT(13)
> +#define DW_UART_CPR_FIFO_MODE          GENMASK(23, 16)
>
>  /* Helper for FIFO size calculation */
> -#define DW_UART_CPR_FIFO_SIZE(a)       (((a >> 16) & 0xff) * 16)
> +#define DW_UART_CPR_FIFO_SIZE(a)       (FIELD_GET(DW_UART_CPR_FIFO_MODE, (a)) * 16)
>
>  /*
>   * divisor = div(I) + div(F)
> --
> 2.30.2
>


-- 
With Best Regards,
Andy Shevchenko

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ