[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <YsCVW5Dt3YcE3TLL@smile.fi.intel.com>
Date: Sat, 2 Jul 2022 21:58:35 +0300
From: Andy Shevchenko <andriy.shevchenko@...ux.intel.com>
To: Christophe JAILLET <christophe.jaillet@...adoo.fr>
Cc: agk@...hat.com, snitzer@...nel.org, dm-devel@...hat.com,
vneethv@...ux.ibm.com, oberpar@...ux.ibm.com, hca@...ux.ibm.com,
gor@...ux.ibm.com, agordeev@...ux.ibm.com,
borntraeger@...ux.ibm.com, svens@...ux.ibm.com,
almaz.alexandrovich@...agon-software.com, yury.norov@...il.com,
linux@...musvillemoes.dk, linux-s390@...r.kernel.org,
ntfs3@...ts.linux.dev, linux-kernel@...r.kernel.org,
kernel-janitors@...r.kernel.org
Subject: Re: [PATCH 2/4] fs/ntfs3: Rename bitmap_size() as ntfs3_bitmap_size()
On Sat, Jul 02, 2022 at 08:29:27PM +0200, Christophe JAILLET wrote:
> In order to introduce a bitmap_size() function in the bitmap API, we have
> to rename functions with a similar name.
...
> /* NTFS uses quad aligned bitmaps. */
> -static inline size_t bitmap_size(size_t bits)
> +static inline size_t ntfs3_bitmap_size(size_t bits)
> {
> return ALIGN((bits + 7) >> 3, 8);
It would be easier to understand in a way
return BITS_TO_BYTES(ALIGN(bits, 64));
> }
--
With Best Regards,
Andy Shevchenko
Powered by blists - more mailing lists