[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20220705154708.181258-1-rppt@kernel.org>
Date: Tue, 5 Jul 2022 18:46:53 +0300
From: Mike Rapoport <rppt@...nel.org>
To: Andrew Morton <akpm@...ux-foundation.org>
Cc: Arnd Bergmann <arnd@...db.de>, Dinh Nguyen <dinguyen@...nel.org>,
Guo Ren <guoren@...nel.org>, Helge Deller <deller@....de>,
Huacai Chen <chenhuacai@...nel.org>,
"James E.J. Bottomley" <James.Bottomley@...senPartnership.com>,
Matthew Wilcox <willy@...radead.org>,
Max Filippov <jcmvbkbc@...il.com>,
Mike Rapoport <rppt@...nel.org>,
Mike Rapoport <rppt@...ux.ibm.com>,
"Russell King (Oracle)" <linux@...linux.org.uk>,
Thomas Bogendoerfer <tsbogend@...ha.franken.de>,
WANG Xuerui <kernel@...0n.name>, linux-arch@...r.kernel.org,
linux-csky@...r.kernel.org, linux-kernel@...r.kernel.org,
linux-mips@...r.kernel.org, linux-mm@...ck.org,
linux-parisc@...r.kernel.org, linux-xtensa@...ux-xtensa.org,
loongarch@...ts.linux.dev
Subject: [PATCH v2 00/15] arch: make PxD_ORDER generically available
From: Mike Rapoport <rppt@...ux.ibm.com>
v2 changes:
* Drop extra blank line in arch/loongarch/kernel/asm-offsets.c (patch 12)
* Add patch 15 that renames PMD_ORDER to PMD_ENTRY_ORDER in
arch/arm/kernel/head.S
v1: https://lore.kernel.org/all/20220703141203.147893-1-rppt@kernel.org
v1 cover letter:
The question what does PxD_ORDER define raises from time to time and
there is still a conflict between MIPS and DAX definitions.
Some time ago Matthew Wilcox suggested to use PMD_TABLE_ORDER to define
the order of page table allocation:
[1] https://lore.kernel.org/linux-arch/YPCJftSTUBEnq2lI@casper.infradead.org/
The parisc patch made it in, but mips didn't.
Now mips defines from asm/include/pgtable.h were copied to loongarch which
made it worse.
Let's deal with it once and for all and rename PxD_ORDER defines to
PxD_TABLE_ORDER or just drop them when the only possible order of page
table is 0.
I think the best way to merge this via mm tree with acks from arch
maintainers.
Matthew Wilcox (Oracle) (1):
mips: Rename PMD_ORDER to PMD_TABLE_ORDER
Mike Rapoport (14):
csky: drop definition of PTE_ORDER
csky: drop definition of PGD_ORDER
mips: Rename PUD_ORDER to PUD_TABLE_ORDER
mips: drop definitions of PTE_ORDER
mips: Rename PGD_ORDER to PGD_TABLE_ORDER
nios2: drop definition of PTE_ORDER
nios2: drop definition of PGD_ORDER
loongarch: drop definition of PTE_ORDER
loongarch: drop definition of PMD_ORDER
loongarch: drop definition of PUD_ORDER
loongarch: drop definition of PGD_ORDER
parisc: Rename PGD_ORDER to PGD_TABLE_ORDER
xtensa: drop definition of PGD_ORDER
ARM: head.S: rename PMD_ORDER to PMD_ENTRY_ORDER
arch/arm/kernel/head.S | 34 ++++++++--------
arch/csky/include/asm/pgalloc.h | 2 +-
arch/csky/include/asm/pgtable.h | 6 +--
arch/loongarch/include/asm/pgalloc.h | 6 +--
arch/loongarch/include/asm/pgtable.h | 27 +++++-------
arch/loongarch/kernel/asm-offsets.c | 6 ---
arch/loongarch/mm/pgtable.c | 2 +-
arch/loongarch/mm/tlbex.S | 6 +--
arch/mips/include/asm/pgalloc.h | 8 ++--
arch/mips/include/asm/pgtable-32.h | 19 ++++-----
arch/mips/include/asm/pgtable-64.h | 61 +++++++++++++---------------
arch/mips/kernel/asm-offsets.c | 5 ---
arch/mips/kvm/mmu.c | 2 +-
arch/mips/mm/pgtable.c | 2 +-
arch/mips/mm/tlbex.c | 14 +++----
arch/nios2/include/asm/pgtable.h | 7 +---
arch/nios2/mm/init.c | 5 +--
arch/nios2/mm/pgtable.c | 2 +-
arch/parisc/include/asm/pgalloc.h | 6 +--
arch/parisc/include/asm/pgtable.h | 8 ++--
arch/xtensa/include/asm/pgalloc.h | 2 +-
arch/xtensa/include/asm/pgtable.h | 1 -
22 files changed, 101 insertions(+), 130 deletions(-)
base-commit: 03c765b0e3b4cb5063276b086c76f7a612856a9a
--
2.34.1
Powered by blists - more mailing lists