lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 12 Jul 2022 10:48:42 +1000
From:   Nicholas Piggin <npiggin@...il.com>
To:     Waiman Long <longman@...hat.com>,
        Peter Zijlstra <peterz@...radead.org>
Cc:     Boqun Feng <boqun.feng@...il.com>, linux-kernel@...r.kernel.org,
        Ingo Molnar <mingo@...hat.com>, Will Deacon <will@...nel.org>
Subject: Re: [PATCH 11/13] locking/qspinlock: Use queued_spin_trylock in
 pv_hybrid_queued_unfair_trylock

Excerpts from Waiman Long's message of July 6, 2022 6:15 am:
> On 7/4/22 10:38, Nicholas Piggin wrote:
>> Rather than open-code it as necessitated by the old function-renaming
>> code generation that rendered queued_spin_trylock unavailable to use
>> here.
>>
>> Signed-off-by: Nicholas Piggin <npiggin@...il.com>
>> ---
>>   kernel/locking/qspinlock.c | 2 +-
>>   1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/kernel/locking/qspinlock.c b/kernel/locking/qspinlock.c
>> index cef0ca7d94e1..9db168753124 100644
>> --- a/kernel/locking/qspinlock.c
>> +++ b/kernel/locking/qspinlock.c
>> @@ -357,7 +357,7 @@ static inline bool pv_hybrid_queued_unfair_trylock(struct qspinlock *lock)
>>   		int val = atomic_read(&lock->val);
>>   
>>   		if (!(val & _Q_LOCKED_PENDING_MASK) &&
>> -		   (cmpxchg_acquire(&lock->locked, 0, _Q_LOCKED_VAL) == 0)) {
>> +				queued_spin_trylock(lock)) {
>>   			lockevent_inc(pv_lock_stealing);
>>   			return true;
>>   		}
> 
> I am not sure if the compiler will eliminate the duplicated 
> atomic_read() in queued_spin_trylock(). So unless it can generate the 
> same code, I would prefer to leave this alone.

Ah you're right, I had that read removed in my tree but then dropped
that change before submitting. This should have been dropped as well.

Thanks,
Nick

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ