[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <62ce1771b331c_6070c294a6@dwillia2-xfh.jf.intel.com.notmuch>
Date: Tue, 12 Jul 2022 17:53:05 -0700
From: Dan Williams <dan.j.williams@...el.com>
To: Jane Chu <jane.chu@...cle.com>, <dan.j.williams@...el.com>,
<linux-kernel@...r.kernel.org>, <hch@....de>,
<nvdimm@...ts.linux.dev>
Subject: RE: [PATCH v2] pmem: fix a name collision
Jane Chu wrote:
> Kernel test robot detected name collision when compiled on 'um'
> architecture. Rename "to_phys()" to "pmem_to_phys()".
>
> >> drivers/nvdimm/pmem.c:48:20: error: conflicting types for 'to_phys'; have 'phys_addr_t(struct pmem_device *, phys_addr_t)' {aka 'long long unsigned int(struct pmem_device *, long long unsigned int)'}
> 48 | static phys_addr_t to_phys(struct pmem_device *pmem, phys_addr_t offset)
> | ^~~~~~~
> In file included from arch/um/include/asm/page.h:98,
> from arch/um/include/asm/thread_info.h:15,
> from include/linux/thread_info.h:60,
> from include/asm-generic/preempt.h:5,
> from ./arch/um/include/generated/asm/preempt.h:1,
>
> arch/um/include/shared/mem.h:12:29: note: previous definition of 'to_phys' with type 'long unsigned int(void *)'
> 12 | static inline unsigned long to_phys(void *virt)
> | ^~~~~~~
>
> vim +48 drivers/nvdimm/pmem.c
> 47
> > 48 static phys_addr_t to_phys(struct pmem_device *pmem, phys_addr_t offset)
> 49 {
> 50 return pmem->phys_addr + offset;
> 51 }
> 52
>
> Fixes: 9409c9b6709e (pmem: refactor pmem_clear_poison())
> Reported-by: kernel test robot <lkp@...el.com>
> Signed-off-by: Jane Chu <jane.chu@...cle.com>
Applied. Sorry for the delay, catching up after vacation.
Powered by blists - more mailing lists