lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Thu, 14 Jul 2022 09:08:27 +0800
From:   Kent Gibson <warthog618@...il.com>
To:     Andy Shevchenko <andy.shevchenko@...il.com>
Cc:     Linux Kernel Mailing List <linux-kernel@...r.kernel.org>,
        "open list:GPIO SUBSYSTEM" <linux-gpio@...r.kernel.org>,
        Bartosz Golaszewski <brgl@...ev.pl>,
        Linus Walleij <linus.walleij@...aro.org>,
        Dipen Patel <dipenp@...dia.com>
Subject: Re: [PATCH 6/6] gpiolib: cdev: compile out HTE unless CONFIG_HTE
 selected

On Wed, Jul 13, 2022 at 06:30:14PM +0800, Kent Gibson wrote:
> On Wed, Jul 13, 2022 at 12:03:07PM +0200, Andy Shevchenko wrote:
> > On Wed, Jul 13, 2022 at 3:39 AM Kent Gibson <warthog618@...il.com> wrote:
> > >
> > > The majority of builds do not include HTE, so compile out hte
> > > functionality unless CONFIG_HTE is selected.
> > 
> > ...
> > 
> > > +#ifdef CONFIG_HTE
> > >         /*
> > >          * -- hte specific fields --
> > >          */
> > 
> > Now this comment seems useless to me and it takes 3 LoCs.
> > 
> > ...
> > 
> > > +       else if (IS_ENABLED(CONFIG_HTE) &&
> > > +                (test_bit(FLAG_EVENT_CLOCK_HTE, &line->desc->flags)))
> > 
> > Too many parentheses.
> > 
> > ...
> > 
> > > +               if (!IS_ENABLED(CONFIG_HTE) ||
> > > +                   !test_bit(FLAG_EVENT_CLOCK_HTE, &line->desc->flags)) {
> > 
> > if (!(x && y)) ?
> > 
> > ...
> > 
> > > +       if (!IS_ENABLED(CONFIG_HTE) &&
> > > +           (flags & GPIO_V2_LINE_FLAG_EVENT_CLOCK_HTE))
> > > +               return -EOPNOTSUPP;
> > 
> > Ditto for consistency?
> > 

On second thought, that last one becomes:

	if (!(IS_ENABLED(CONFIG_HTE) ||
	      !(flags & GPIO_V2_LINE_FLAG_EVENT_CLOCK_HTE))
		return -EOPNOTSUPP;

which is MUCH less readable, so I'll leave that one as is.

Cheers,
Kent.

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ