[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <634d07cf-596d-c116-df41-3e4ad05179c5@nvidia.com>
Date: Thu, 14 Jul 2022 22:10:01 -0700
From: Dipen Patel <dipenp@...dia.com>
To: Kent Gibson <warthog618@...il.com>, linux-kernel@...r.kernel.org,
linux-gpio@...r.kernel.org, brgl@...ev.pl,
linus.walleij@...aro.org, andy.shevchenko@...il.com
Subject: Re: [PATCH v2 2/6] gpiolib: cdev: simplify parameter in call to
hte_edge_setup
On 7/13/22 7:03 PM, Kent Gibson wrote:
> Improve readability by using the GPIO_V2_LINE_FLAG_EDGE_BOTH instead
> of combining the rising and falling edge flags.
>
> Signed-off-by: Kent Gibson <warthog618@...il.com>
> Reviewed-by: Andy Shevchenko <andy.shevchenko@...il.com>
> ---
> drivers/gpio/gpiolib-cdev.c | 4 +---
> 1 file changed, 1 insertion(+), 3 deletions(-)
>
> diff --git a/drivers/gpio/gpiolib-cdev.c b/drivers/gpio/gpiolib-cdev.c
> index b44526e3630e..f635bbbb6a6d 100644
> --- a/drivers/gpio/gpiolib-cdev.c
> +++ b/drivers/gpio/gpiolib-cdev.c
> @@ -885,9 +885,7 @@ static int debounce_setup(struct line *line,
> return ret;
> line->irq = irq;
> } else {
> - ret = hte_edge_setup(line,
> - GPIO_V2_LINE_FLAG_EDGE_RISING |
> - GPIO_V2_LINE_FLAG_EDGE_FALLING);
> + ret = hte_edge_setup(line, GPIO_V2_LINE_FLAG_EDGE_BOTH);
> if (ret)
> return ret;
> }
Acked-by: Dipen Patel <dipenp@...dia.com>
Powered by blists - more mailing lists