[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAHp75Vc7wNkhG2dL=0vVZq5paDQy_8+WJ25Jk4E8SG2TW6EZdw@mail.gmail.com>
Date: Fri, 15 Jul 2022 20:13:49 +0200
From: Andy Shevchenko <andy.shevchenko@...il.com>
To: ChiaEn Wu <peterwu.pub@...il.com>
Cc: Lee Jones <lee.jones@...aro.org>,
Daniel Thompson <daniel.thompson@...aro.org>,
Jingoo Han <jingoohan1@...il.com>, Pavel Machek <pavel@....cz>,
Rob Herring <robh+dt@...nel.org>,
Krzysztof Kozlowski <krzysztof.kozlowski+dt@...aro.org>,
Matthias Brugger <matthias.bgg@...il.com>,
Sebastian Reichel <sre@...nel.org>,
Chunfeng Yun <chunfeng.yun@...iatek.com>,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
Jonathan Cameron <jic23@...nel.org>,
Lars-Peter Clausen <lars@...afoo.de>,
Liam Girdwood <lgirdwood@...il.com>,
Mark Brown <broonie@...nel.org>,
Guenter Roeck <linux@...ck-us.net>,
"Krogerus, Heikki" <heikki.krogerus@...ux.intel.com>,
Helge Deller <deller@....de>,
ChiaEn Wu <chiaen_wu@...htek.com>,
Alice Chen <alice_chen@...htek.com>,
cy_huang <cy_huang@...htek.com>,
dri-devel <dri-devel@...ts.freedesktop.org>,
Linux LED Subsystem <linux-leds@...r.kernel.org>,
devicetree <devicetree@...r.kernel.org>,
linux-arm Mailing List <linux-arm-kernel@...ts.infradead.org>,
"moderated list:ARM/Mediatek SoC support"
<linux-mediatek@...ts.infradead.org>,
Linux Kernel Mailing List <linux-kernel@...r.kernel.org>,
Linux PM <linux-pm@...r.kernel.org>,
USB <linux-usb@...r.kernel.org>,
linux-iio <linux-iio@...r.kernel.org>,
"open list:FRAMEBUFFER LAYER" <linux-fbdev@...r.kernel.org>,
szuni chen <szunichen@...il.com>
Subject: Re: [PATCH v5 12/13] leds: flashlight: mt6370: Add MediaTek MT6370
flashlight support
On Fri, Jul 15, 2022 at 1:29 PM ChiaEn Wu <peterwu.pub@...il.com> wrote:
> The MediaTek MT6370 is a highly-integrated smart power management IC,
> whichincludes a single cell Li-Ion/Li-Polymer switching battery
which includes
> charger, a USB Type-C & Power Delivery (PD) controller, dual Flash
> LED current sources, a RGB LED driver, a backlight WLED driver,
> a display bias driver and a general LDO for portable devices.
>
> The Flash LED in MT6370 has 2 channel and support torch/strobe mode.
channels
> The commit add the support of MT6370 FLASH LED.
Add the
...
> +#define MT6370_FLCSEN_MASK_ALL (BIT(0) | BIT(1))
GENMASK()
...
> + for (i = 0; i < MT6370_MAX_LEDS; i++) {
> + ret = regmap_update_bits(priv->regmap,
> + MT6370_REG_FLEDISTRB(i),
> + MT6370_ISTROBE_MASK, flevel[i]);
> + if (ret)
> + return ret;
> + }
> + } else {
> + ret = regmap_update_bits(priv->regmap,
> + MT6370_REG_FLEDISTRB(led->led_no),
> + MT6370_ISTROBE_MASK, val);
> + }
> + return ret;
return regmap_update_bits(...);
}
return 0;
...
> + /*
> + * If the flash need to be on,
needs
> + * config the flash current ramping up to the setting value.
> + * Else, always recover back to the minimum one.
> + */
...
> + /* For the flash turn on/off, need to wait HW ramping up/down time
to turn
> + * 5ms/500us to prevent the unexpected problem.
> + */
Wrong multi-line comment style.
> +
No need for a blank line.
> + if (!prev && curr)
> + usleep_range(5000, 6000);
> + else if (prev && !curr)
> + udelay(500);
...
> +static int mt6370_led_register(struct device *parent, struct mt6370_led *led,
> + struct led_init_data *init_data)
> +{
> + struct v4l2_flash_config v4l2_config = {0};
> + int ret;
> +
> + ret = devm_led_classdev_flash_register_ext(parent, &led->flash,
> + init_data);
> + if (ret) {
> + dev_err(parent, "Couldn't register flash %d\n", led->led_no);
> + return ret;
return dev_err_probe() here and everywhere where it is about probe stage.
> + }
> +
> + mt6370_init_v4l2_flash_config(led, &v4l2_config);
> + led->v4l2_flash = v4l2_flash_init(parent, init_data->fwnode,
> + &led->flash, &v4l2_flash_ops,
> + &v4l2_config);
> + if (IS_ERR(led->v4l2_flash)) {
> + dev_err(parent, "Failed to register %d v4l2 sd\n", led->led_no);
> + return PTR_ERR(led->v4l2_flash);
> + }
> +
> + return 0;
> +}
...
> + num = fwnode_property_count_u32(init_data->fwnode, "led-sources");
> + if (num < 1 || num > MT6370_MAX_LEDS) {
> + dev_err(priv->dev,
> + "Not specified or wrong number of led-sources\n");
> + return -EINVAL;
Ditto.
> + }
...
> + ret = fwnode_property_read_u32(init_data->fwnode, "led-max-microamp",
> + &val);
One line?
...
> + val = clamp_align(val, MT6370_STRBTO_MIN_US, MT6370_STRBTO_MAX_US,
> + MT6370_STRBTO_STEP_US);
I would name it mt6370_clamp() to avoid potential collision in the
global namespace in the future.
--
With Best Regards,
Andy Shevchenko
Powered by blists - more mailing lists