[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <Yt8oOHvNO2nnBQwM@google.com>
Date: Mon, 25 Jul 2022 23:33:12 +0000
From: Sean Christopherson <seanjc@...gle.com>
To: David Matlack <dmatlack@...gle.com>
Cc: Paolo Bonzini <pbonzini@...hat.com>, kvm@...r.kernel.org,
linux-kernel@...r.kernel.org, Yosry Ahmed <yosryahmed@...gle.com>,
Mingwei Zhang <mizhang@...gle.com>,
Ben Gardon <bgardon@...gle.com>
Subject: Re: [PATCH v2 5/6] KVM: x86/mmu: Add helper to convert SPTE value to
its shadow page
On Mon, Jul 25, 2022, David Matlack wrote:
> On Sat, Jul 23, 2022 at 01:23:24AM +0000, Sean Christopherson wrote:
> > Add a helper to convert a SPTE to its shadow page to deduplicate a
> > variety of flows and hopefully avoid future bugs, e.g. if KVM attempts to
> > get the shadow page for a SPTE without dropping high bits.
> >
> > Opportunistically add a comment in mmu_free_root_page() documenting why
> > it treats the root HPA as a SPTE.
> >
> > No functional change intended.
> >
> > Signed-off-by: Sean Christopherson <seanjc@...gle.com>
> > ---
> [...]
> > --- a/arch/x86/kvm/mmu/spte.h
> > +++ b/arch/x86/kvm/mmu/spte.h
> > @@ -207,6 +207,23 @@ static inline int spte_index(u64 *sptep)
> > */
> > extern u64 __read_mostly shadow_nonpresent_or_rsvd_lower_gfn_mask;
> >
> > +static inline struct kvm_mmu_page *to_shadow_page(hpa_t shadow_page)
> > +{
> > + struct page *page = pfn_to_page((shadow_page) >> PAGE_SHIFT);
> > +
> > + return (struct kvm_mmu_page *)page_private(page);
> > +}
> > +
> > +static inline struct kvm_mmu_page *spte_to_sp(u64 spte)
> > +{
> > + return to_shadow_page(spte & SPTE_BASE_ADDR_MASK);
> > +}
>
> spte_to_sp() and sptep_to_sp() are a bit hard to differentiate visually.
Yeah, I balked a bit when making the change, but couldn't come up with a better
alternative.
> Maybe spte_to_child_sp() or to_child_sp()?
I like to_child_sp(). Apparently I have a mental block when it comes to parent
vs. child pages and never realized that sptep_to_sp() gets the "parent" but
spte_to_sp() gets the "child". That indeed makes spte_to_sp() a bad name.
Powered by blists - more mailing lists