[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <833d605d-0605-9439-6544-885e6f5f75b0@roeck-us.net>
Date: Tue, 26 Jul 2022 08:05:07 -0700
From: Guenter Roeck <linux@...ck-us.net>
To: Andy Shevchenko <andriy.shevchenko@...ux.intel.com>,
Eddie James <eajames@...ux.ibm.com>,
linux-hwmon@...r.kernel.org, linux-kernel@...r.kernel.org
Cc: Jean Delvare <jdelvare@...e.com>
Subject: Re: [PATCH v1 1/1] hwmon: (occ) Replace open-coded variant of %*phN
specifier
On 7/26/22 07:31, Andy Shevchenko wrote:
> printf()-like functions in the kernel have extensions, such as
> %*phN to dump small pieces of memory as hex bytes.
>
> Replace custom approach with the direct use of %*phN.
>
> Signed-off-by: Andy Shevchenko <andriy.shevchenko@...ux.intel.com>
Applied.
Thanks,
Guenter
> ---
> drivers/hwmon/occ/common.c | 8 ++------
> 1 file changed, 2 insertions(+), 6 deletions(-)
>
> diff --git a/drivers/hwmon/occ/common.c b/drivers/hwmon/occ/common.c
> index 157b73a3da29..45407b12db4b 100644
> --- a/drivers/hwmon/occ/common.c
> +++ b/drivers/hwmon/occ/common.c
> @@ -729,18 +729,14 @@ static ssize_t occ_show_extended(struct device *dev,
> rc = sysfs_emit(buf, "%u",
> get_unaligned_be32(&extn->sensor_id));
> } else {
> - rc = sysfs_emit(buf, "%02x%02x%02x%02x\n",
> - extn->name[0], extn->name[1],
> - extn->name[2], extn->name[3]);
> + rc = sysfs_emit(buf, "%4phN\n", extn->name);
> }
> break;
> case 1:
> rc = sysfs_emit(buf, "%02x\n", extn->flags);
> break;
> case 2:
> - rc = sysfs_emit(buf, "%02x%02x%02x%02x%02x%02x\n",
> - extn->data[0], extn->data[1], extn->data[2],
> - extn->data[3], extn->data[4], extn->data[5]);
> + rc = sysfs_emit(buf, "%6phN\n", extn->data);
> break;
> default:
> return -EINVAL;
Powered by blists - more mailing lists