[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <fe43a69a23308580eac251fdfdde66d848b64381.camel@svanheule.net>
Date: Thu, 28 Jul 2022 20:40:33 +0200
From: Sander Vanheule <sander@...nheule.net>
To: Martin Blumenstingl <martin.blumenstingl@...glemail.com>,
linux-spi@...r.kernel.org
Cc: linux-kernel@...r.kernel.org, bert@...t.com, mail@...ger-koblitz.de
Subject: Re: [PATCH v2 2/2] spi: realtek-rtl: Improve readability when
clearing the size mask
On Thu, 2022-07-28 at 17:21 +0200, Martin Blumenstingl wrote:
> Define the bitmask RTL_SPI_SFCSR_LEN_MASK so it only sets the bits of
> this specific part of the register instead of setting all bits except
> the relevant ones. This makes it consistent with single bit macros in
> the spi-realtek-rtl driver as well as with the approach that many other
> drivers use.
>
> Suggested-by: Sander Vanheule <sander@...nheule.net>
> Signed-off-by: Martin Blumenstingl <martin.blumenstingl@...glemail.com>
FWIW
Tested-by: Sander Vanheule <sander@...nheule.net>
on my Netgear GS110TPP v1.
> ---
> drivers/spi/spi-realtek-rtl.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/spi/spi-realtek-rtl.c b/drivers/spi/spi-realtek-rtl.c
> index 866b0477dbd7..0371d44cbfbd 100644
> --- a/drivers/spi/spi-realtek-rtl.c
> +++ b/drivers/spi/spi-realtek-rtl.c
> @@ -20,7 +20,7 @@ struct rtspi {
> #define RTL_SPI_SFCSR_CSB1 BIT(30)
> #define RTL_SPI_SFCSR_RDY BIT(27)
> #define RTL_SPI_SFCSR_CS BIT(24)
> -#define RTL_SPI_SFCSR_LEN_MASK ~(0x03 << 28)
> +#define RTL_SPI_SFCSR_LEN_MASK (0x03 << 28)
> #define RTL_SPI_SFCSR_LEN1 (0x00 << 28)
> #define RTL_SPI_SFCSR_LEN4 (0x03 << 28)
>
> @@ -49,7 +49,7 @@ static void set_size(struct rtspi *rtspi, int size)
> u32 value;
>
> value = readl(REG(RTL_SPI_SFCSR));
> - value &= RTL_SPI_SFCSR_LEN_MASK;
> + value &= ~RTL_SPI_SFCSR_LEN_MASK;
> if (size == 4)
> value |= RTL_SPI_SFCSR_LEN4;
> else if (size == 1)
Powered by blists - more mailing lists