[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <0085fdd057687637ebd5a7688897a279e72e03f6.camel@mediatek.com>
Date: Mon, 1 Aug 2022 20:04:21 +0800
From: Yong Wu <yong.wu@...iatek.com>
To: Tinghan Shen <tinghan.shen@...iatek.com>,
Joerg Roedel <joro@...tes.org>, Will Deacon <will@...nel.org>,
Robin Murphy <robin.murphy@....com>,
"Rob Herring" <robh+dt@...nel.org>,
Krzysztof Kozlowski <krzysztof.kozlowski+dt@...aro.org>,
Lee Jones <lee@...nel.org>,
"Matthias Brugger" <matthias.bgg@...il.com>,
AngeloGioacchino Del Regno
<angelogioacchino.delregno@...labora.com>,
MandyJH Liu <mandyjh.liu@...iatek.com>
CC: <iommu@...ts.linux.dev>, <linux-mediatek@...ts.infradead.org>,
<devicetree@...r.kernel.org>, <linux-kernel@...r.kernel.org>,
<linux-arm-kernel@...ts.infradead.org>,
<Project_Global_Chrome_Upstream_Group@...iatek.com>,
<chengci.xu@...iatek.com>
Subject: Re: [PATCH v4 01/20] dt-bindings: iommu: mediatek: Increase max
interrupt number
On Fri, 2022-07-29 at 14:31 +0800, Tinghan Shen wrote:
> mt8195 infra iommu uses 5 interrupts.
>
> Signed-off-by: Tinghan Shen <tinghan.shen@...iatek.com>
> Reviewed-by: Krzysztof Kozlowski <krzysztof.kozlowski@...aro.org>
> ---
> .../bindings/iommu/mediatek,iommu.yaml | 18
> +++++++++++++++++-
> 1 file changed, 17 insertions(+), 1 deletion(-)
>
> diff --git
> a/Documentation/devicetree/bindings/iommu/mediatek,iommu.yaml
> b/Documentation/devicetree/bindings/iommu/mediatek,iommu.yaml
> index fee0241b50988..5afe2a0045330 100644
> --- a/Documentation/devicetree/bindings/iommu/mediatek,iommu.yaml
> +++ b/Documentation/devicetree/bindings/iommu/mediatek,iommu.yaml
> @@ -91,7 +91,8 @@ properties:
> maxItems: 1
>
> interrupts:
> - maxItems: 1
> + minItems: 1
> + maxItems: 5
>
> clocks:
> items:
> @@ -191,9 +192,24 @@ allOf:
> const: mediatek,mt8195-iommu-infra
>
> then:
> + properties:
> + interrupts:
> + maxItems: 1
> +
> required:
> - mediatek,larbs
>
> + else:
> + properties:
> + interrupts:
> + description: The IOMMU has 5 banks. Each bank has its own
> interrupt.
> + items:
> + - description: The interrupt for IOMMU bank0
> + - description: The interrupt for IOMMU bank1
> + - description: The interrupt for IOMMU bank2
> + - description: The interrupt for IOMMU bank3
> + - description: The interrupt for IOMMU bank4
> +
Thanks for improving this.
Before the meaning for this segment is that it require "mediatek,larbs"
if it is NOT infra iommu. Here we add a new block for infra iommu.
then we'd better to remove the "not". this should be more readable.
Something like below:
if:
/* Remove the not here. */
properties:
compatible:
contains:
const: mediatek,mt8195-iommu-infra
then:
xxx
else:
xx
> additionalProperties: false
>
> examples:
Powered by blists - more mailing lists