[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <YvQMyQLohqcc8Fug@ripper>
Date: Wed, 10 Aug 2022 12:53:45 -0700
From: Bjorn Andersson <bjorn.andersson@...aro.org>
To: Rudraksha Gupta <guptarud@...il.com>
Cc: agross@...nel.org, david@...t.cz, devicetree@...r.kernel.org,
krzysztof.kozlowski+dt@...aro.org, linux-arm-msm@...r.kernel.org,
linux-kernel@...r.kernel.org, robh+dt@...nel.org
Subject: Re: [PATCH v2 1/2] ARM: msm8960: Rename cxo_board to cxo-board and
add alias
On Mon 08 Aug 17:02 PDT 2022, Rudraksha Gupta wrote:
> This patch renames cxo_board to be up to date with the current naming
> style. It also adds an alias.
>
> Signed-off-by: Rudraksha Gupta <guptarud@...il.com>
> ---
> v2:
> - Group the correct changes together
>
> arch/arm/boot/dts/qcom-msm8960.dtsi | 2 +-
> drivers/clk/qcom/gcc-msm8960.c | 2 +-
Clock and dts patches goes through two different paths towards mainline,
so they should be separated.
> 2 files changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/arch/arm/boot/dts/qcom-msm8960.dtsi b/arch/arm/boot/dts/qcom-msm8960.dtsi
> index 0e099aa7c889..2ed969785b78 100644
> --- a/arch/arm/boot/dts/qcom-msm8960.dtsi
> +++ b/arch/arm/boot/dts/qcom-msm8960.dtsi
> @@ -58,7 +58,7 @@ cpu-pmu {
> };
>
> clocks {
> - cxo_board {
> + cxo_board: cxo-board {
> compatible = "fixed-clock";
> #clock-cells = <0>;
> clock-frequency = <19200000>;
> diff --git a/drivers/clk/qcom/gcc-msm8960.c b/drivers/clk/qcom/gcc-msm8960.c
> index 051745ef99c8..56ce05a846dd 100644
> --- a/drivers/clk/qcom/gcc-msm8960.c
> +++ b/drivers/clk/qcom/gcc-msm8960.c
> @@ -3624,7 +3624,7 @@ static int gcc_msm8960_probe(struct platform_device *pdev)
> if (!match)
> return -EINVAL;
>
> - ret = qcom_cc_register_board_clk(dev, "cxo_board", "cxo", 19200000);
> + ret = qcom_cc_register_board_clk(dev, "cxo-board", "cxo", 19200000);
This breaks compatibility with existing DTB files.
What you probably want is to make sure that any clocks with parent name
of "cxo", should have a .fw_name = "cxo", then you can make a
phandle-based reference in DT and these global names doesn't matter (and
in the end we can remove this board_clk from the driver).
Regards,
Bjorn
> if (ret)
> return ret;
>
> --
> 2.25.1
>
Powered by blists - more mailing lists