[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <dd41c5c3-ee16-821c-afd4-ddda4443bc78@huawei.com>
Date: Fri, 19 Aug 2022 09:10:03 +0100
From: John Garry <john.garry@...wei.com>
To: Andy Shevchenko <andy.shevchenko@...il.com>
CC: Len Brown <lenb@...nel.org>,
"Rafael J. Wysocki" <rafael@...nel.org>,
"ACPI Devel Maling List" <linux-acpi@...r.kernel.org>,
Linux Kernel Mailing List <linux-kernel@...r.kernel.org>,
Linuxarm <linuxarm@...wei.com>
Subject: Re: [PATCH PoC 2/3] ACPI: platform: Refactor
acpi_create_platform_device()
On 18/08/2022 20:41, Andy Shevchenko wrote:
> On Tue, Aug 16, 2022 at 2:33 PM John Garry <john.garry@...wei.com> wrote:
>>
>> There is commonality between acpi_create_platform_device() and
>> hisi_lpc_acpi_add_child(), in that it covers 2x main steps:
>> - Read resources for the acpi_device
>> - Create platform device
>>
>> Refactor acpi_create_platform_device() so that it may be reused by
>> hisi_lpc_acpi_add_child() to reduce duplication.
>
> ...
>
>> + * acpi_create_platform_device_ops - Create platform device for ACPI device node
>
> Not sure I understand why _ops is a suffix for the function. I would
> expect _ops to be a data struct where the ->xlate() and perhaps other
> callbacks may be collected. It may be that I have missed that portion
> in the previous discussion.
ok, maybe I can put all the members into a struct, but I don't think
that it improves the overall code too much.
>
> ...
>
>> + if (name)
>> + pdevinfo.name = name;
>> + else
>> + pdevinfo.name = dev_name(&adev->dev);
>
>> + pdevinfo.data = data;
>> + pdevinfo.size_data = size_data;
>
> It rather reminds me of platform device registration full with this
> device info. May be what you need is
> struct acpi_platfrom_device_info {
> properties;
> name;
> id;
> ->xlate();
> ...
> };
>
> ?
>
> ...
>
>> +struct platform_device *acpi_create_platform_device_ops(
>> + struct acpi_device *adev,
>> + const char *name,
>> + const struct property_entry *properties,
>> + void *data, size_t size_data,
>> + int (*xlat)(struct acpi_device *adev,
>> + struct resource *res,
>> + void *data, size_t size_data),
>> + int id);
>
> ...because this looks a bit too much from the amount of parameters
> point of view.
>
ok, agreed.
But even if we improve this code, the hisi_lpc changes are quite large
and unwieldly.
Thanks,
John
Powered by blists - more mailing lists