[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20220826073337.2085798-2-yangyingliang@huawei.com>
Date: Fri, 26 Aug 2022 15:33:36 +0800
From: Yang Yingliang <yangyingliang@...wei.com>
To: <linux-kernel@...r.kernel.org>
CC: <mhiramat@...nel.org>, <ast@...nel.org>, <jbacik@...com>,
<akpm@...ux-foundation.org>
Subject: [PATCH -next 2/3] fail_function: refctor code of checking return value of register_kprobe()
Refactor the error handling of register_kprobe() to improve readability.
No functional change.
Signed-off-by: Yang Yingliang <yangyingliang@...wei.com>
---
kernel/fail_function.c | 11 +++++------
1 file changed, 5 insertions(+), 6 deletions(-)
diff --git a/kernel/fail_function.c b/kernel/fail_function.c
index 03643e33e4c3..893e8f9a9118 100644
--- a/kernel/fail_function.c
+++ b/kernel/fail_function.c
@@ -294,14 +294,13 @@ static ssize_t fei_write(struct file *file, const char __user *buffer,
}
ret = register_kprobe(&attr->kp);
- if (!ret)
- fei_debugfs_add_attr(attr);
- if (ret < 0)
+ if (ret) {
fei_attr_remove(attr);
- else {
- list_add_tail(&attr->list, &fei_attr_list);
- ret = count;
+ goto out;
}
+ fei_debugfs_add_attr(attr);
+ list_add_tail(&attr->list, &fei_attr_list);
+ ret = count;
out:
mutex_unlock(&fei_lock);
kfree(buf);
--
2.25.1
Powered by blists - more mailing lists