[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20220829204930.27wg2htgbq23kgeg@builder.lan>
Date: Mon, 29 Aug 2022 15:49:30 -0500
From: Bjorn Andersson <andersson@...nel.org>
To: Krzysztof Kozlowski <krzysztof.kozlowski@...aro.org>
Cc: Andy Gross <agross@...nel.org>,
Bjorn Andersson <bjorn.andersson@...aro.org>,
Rob Herring <robh+dt@...nel.org>,
Krzysztof Kozlowski <krzysztof.kozlowski+dt@...aro.org>,
linux-arm-msm@...r.kernel.org, devicetree@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH v6 2/3] soc: qcom: socinfo: create soc_id table from
bindings
On Tue, Jul 05, 2022 at 03:02:59PM +0200, Krzysztof Kozlowski wrote:
> The Qualcomm SoC ID values are encoded in few places: DTS files,
> Devicetree bindings (both used by some of Qualcomm bootloaders or tools)
> and in soc_id table of socinfo driver. Do not duplicate the actual
> values in the last one but use the constants from the bindings.
>
> Tested by comparing output object file (exactly the same).
>
> Signed-off-by: Krzysztof Kozlowski <krzysztof.kozlowski@...aro.org>
I didn't have a strong opinion either way on this, so was hoping someone
else would chime in. Doesn't seem like that has happened, but
unfortunately the soc_id[] list has changed.
Would you mind rebasing the two patches to match the latest list?
> ---
> drivers/soc/qcom/socinfo.c | 259 +++++++++++++++++++------------------
> 1 file changed, 133 insertions(+), 126 deletions(-)
>
> diff --git a/drivers/soc/qcom/socinfo.c b/drivers/soc/qcom/socinfo.c
> index cee579a267a6..d515d3a97f0e 100644
> --- a/drivers/soc/qcom/socinfo.c
> +++ b/drivers/soc/qcom/socinfo.c
> @@ -12,11 +12,14 @@
> #include <linux/slab.h>
> #include <linux/soc/qcom/smem.h>
> #include <linux/string.h>
> +#include <linux/stringify.h>
> #include <linux/sys_soc.h>
> #include <linux/types.h>
>
> #include <asm/unaligned.h>
>
> +#include <dt-bindings/arm/qcom,ids.h>
> +
> /*
> * SoC version type with major number in the upper 16 bits and minor
> * number in the lower 16 bits.
> @@ -25,6 +28,10 @@
> #define SOCINFO_MINOR(ver) ((ver) & 0xffff)
> #define SOCINFO_VERSION(maj, min) ((((maj) & 0xffff) << 16)|((min) & 0xffff))
>
> +/* Helper macros to create soc_id table */
> +#define qcom_board_id(id) QCOM_ID_ ## id, __stringify(id)
> +#define qcom_board_id2(id, name) QCOM_ID_ ## id, (name)
How about naming this qcom_board_id_named() ?
Regards,
Bjorn
Powered by blists - more mailing lists