[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <Yw76KBJ2+uulyC/Q@kroah.com>
Date: Wed, 31 Aug 2022 08:05:28 +0200
From: Greg KH <gregkh@...uxfoundation.org>
To: Nick Desaulniers <ndesaulniers@...gle.com>
Cc: Kees Cook <keescook@...omium.org>,
Nathan Chancellor <nathan@...nel.org>,
Tom Rix <trix@...hat.com>, linux-hardening@...r.kernel.org,
linux-kernel@...r.kernel.org, llvm@...ts.linux.dev,
Jiri Kosina <jikos@...nel.org>,
Benjamin Tissoires <benjamin.tissoires@...hat.com>,
linux-input@...r.kernel.org, Masahiro Yamada <masahiroy@...nel.org>
Subject: Re: [PATCH 3/3] HID: avoid runtime call to strlen
On Tue, Aug 30, 2022 at 01:53:09PM -0700, Nick Desaulniers wrote:
> While looking into a CONFIG_FORTIFY=y related bug, I noticed that
> hid_allocate calls strlen() on a local C string variable. This variable
> can only have literal string values. There is no benefit to having
> FORTIFY have this be a checked strlen call, because these are literal
> values. By calling strlen() explicitly in the branches of a switch, the
> compiler can evaluate strlen("literal value") at compile time, rather
> than at runtime.
>
> Signed-off-by: Nick Desaulniers <ndesaulniers@...gle.com>
> ---
> drivers/hid/hid-input.c | 13 ++++++++++++-
> 1 file changed, 12 insertions(+), 1 deletion(-)
>
> diff --git a/drivers/hid/hid-input.c b/drivers/hid/hid-input.c
> index 48c1c02c69f4..9ad3cc88c26b 100644
> --- a/drivers/hid/hid-input.c
> +++ b/drivers/hid/hid-input.c
> @@ -1922,12 +1922,15 @@ static struct hid_input *hidinput_allocate(struct hid_device *hid,
> switch (application) {
> case HID_GD_KEYBOARD:
> suffix = "Keyboard";
> + suffix_len = strlen(suffix);
> break;
> case HID_GD_KEYPAD:
> suffix = "Keypad";
> + suffix_len = strlen(suffix);
> break;
> case HID_GD_MOUSE:
> suffix = "Mouse";
> + suffix_len = strlen(suffix);
<snip>
This seems ripe for someone to come along and go "look at this cleanup
patch where I move all of this duplicated code to below it in one line!"
As this is a compiler bug, why not fix the compiler? Or at least put a
comment in here saying why this looks so odd to prevent it from being
changed in the future.
thanks,
greg k-h
Powered by blists - more mailing lists