[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <YxZSUlCPEE9o/s4G@google.com>
Date: Mon, 5 Sep 2022 12:47:30 -0700
From: Dmitry Torokhov <dmitry.torokhov@...il.com>
To: Guenter Roeck <linux@...ck-us.net>
Cc: Andy Shevchenko <andy.shevchenko@...il.com>,
Thierry Reding <thierry.reding@...il.com>,
Mark Brown <broonie@...nel.org>,
Matti Vaittinen <mazziesaccount@...il.com>,
Lorenzo Pieralisi <lpieralisi@...nel.org>,
Claudiu Beznea <claudiu.beznea@...rochip.com>,
Liam Girdwood <lgirdwood@...il.com>,
Wim Van Sebroeck <wim@...ux-watchdog.org>,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
Miquel Raynal <miquel.raynal@...tlin.com>,
Linus Walleij <linus.walleij@...aro.org>,
Felipe Balbi <balbi@...nel.org>,
Alexandre Belloni <alexandre.belloni@...tlin.com>,
Krzysztof Wilczyński <kw@...ux.com>,
Vignesh Raghavendra <vigneshr@...com>,
Daniel Vetter <daniel@...ll.ch>,
Thomas Petazzoni <thomas.petazzoni@...tlin.com>,
Alexandre Torgue <alexandre.torgue@...s.st.com>,
Marc Zyngier <maz@...nel.org>,
Richard Weinberger <richard@....at>,
David Airlie <airlied@...ux.ie>,
Nicolas Ferre <nicolas.ferre@...rochip.com>,
Alyssa Rosenzweig <alyssa@...enzweig.io>,
Bartosz Golaszewski <brgl@...ev.pl>,
Jonathan Hunter <jonathanh@...dia.com>,
Rob Herring <robh@...nel.org>,
Maxime Coquelin <mcoquelin.stm32@...il.com>,
Bjorn Helgaas <bhelgaas@...gle.com>,
Pali Rohár <pali@...nel.org>,
LINUXWATCHDOG <linux-watchdog@...r.kernel.org>,
USB <linux-usb@...r.kernel.org>,
"open list:GPIO SUBSYSTEM" <linux-gpio@...r.kernel.org>,
linux-pci <linux-pci@...r.kernel.org>,
linux-tegra <linux-tegra@...r.kernel.org>,
"open list:MEMORY TECHNOLOGY..." <linux-mtd@...ts.infradead.org>,
Linux Kernel Mailing List <linux-kernel@...r.kernel.org>,
dri-devel <dri-devel@...ts.freedesktop.org>,
linux-stm32@...md-mailman.stormreply.com,
linux-arm Mailing List <linux-arm-kernel@...ts.infradead.org>
Subject: Re: [PATCH v1 10/11] watchdog: bd9576_wdt: switch to using
devm_fwnode_gpiod_get()
On Mon, Sep 05, 2022 at 08:49:58AM -0700, Guenter Roeck wrote:
> On 9/5/22 08:21, Andy Shevchenko wrote:
> > On Mon, Sep 5, 2022 at 6:13 PM Guenter Roeck <linux@...ck-us.net> wrote:
> > > On 9/5/22 04:09, Andy Shevchenko wrote:
> > > > On Mon, Sep 5, 2022 at 9:33 AM Dmitry Torokhov
> > > > <dmitry.torokhov@...il.com> wrote:
> >
> > ...
> >
> > > > > + count = device_property_count_u32(dev->parent, "rohm,hw-timeout-ms");
> > > > > + if (count < 0 && count != -EINVAL)
> > > > > + return count;
> > > > > +
> > > > > + if (count > 0) {
> > > >
> > > > > + if (count > ARRAY_SIZE(hw_margin))
> > > > > + return -EINVAL;
> > > >
> > > > Why double check? You may move it out of the (count > 0).
> >
> > > Two checks will always be needed, so I don't entirely see
> > > how that would be better.
> >
> > But not nested. That's my point:
> >
> > if (count > ARRAY_SIZE())
> > return ...
> > if (count > 0)
> > ...
> >
>
> The old code has either 1 or two checks if there is no error.
> Your suggested code has always two checks. I don't see how that
> is an improvement.
>
> > > > > - if (ret == 1)
> > > > > - hw_margin_max = hw_margin[0];
> > > >
> > > > > + ret = device_property_read_u32_array(dev->parent,
> > > > > + "rohm,hw-timeout-ms",
> > > > > + hw_margin, count);
> > > > > + if (ret < 0)
> > > > > + return ret;
> > > >
> > > > So, only this needs the count > 0 check since below already has it implicitly.
> > > >
> > > Sorry, I don't understand this comment.
> >
> > if (count > 0) {
> > ret = device_property_read_u32_array(...);
> > ...
> > }
> > if (count == 1)
> > ...
> > if (count == 2)
> > ...
> >
> > But here it might be better to have the nested conditionals.
> >
>
> We know that count is either 1 or 2 here, so strictly speaking
> if (count == 1) {
> } else {
> }
> would be sufficient. On the other side, that depends on ARRAY_SIZE() being
> exactly 2, so
> if (count == 1) {
> } else if (count == 2) {
> }
> would also make sense. Either way is fine with me. I'll leave it up
> to Dmitry to decide what he wants to do.
My goal is to drop usage of devm_gpiod_get_from_of_node(), beyond that I
do not have strong preferences either way really. It is probing code, so
performance is not critical, but I'm obviously satisfied with how the
code looks now, or I would not have sent it.
Thanks.
--
Dmitry
Powered by blists - more mailing lists