[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20220914115723.38271-1-xhao@linux.alibaba.com>
Date: Wed, 14 Sep 2022 19:57:23 +0800
From: Xin Hao <xhao@...ux.alibaba.com>
To: sj@...nel.org
Cc: akpm@...ux-foundation.org, damon@...ts.linux.dev,
linux-mm@...ck.org, linux-kernel@...r.kernel.org,
xhao@...ux.alibaba.com
Subject: [PATCH] mm/hugetlbfs: use macro SZ_1K to replace 1024
Using macro SZ_1K in hugetlbfs_show_options() has no any functional
changes, just makes code more readable.
Signed-off-by: Xin Hao <xhao@...ux.alibaba.com>
---
fs/hugetlbfs/inode.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/fs/hugetlbfs/inode.c b/fs/hugetlbfs/inode.c
index f7a5b5124d8a..9b9784ffe8de 100644
--- a/fs/hugetlbfs/inode.c
+++ b/fs/hugetlbfs/inode.c
@@ -1023,10 +1023,10 @@ static int hugetlbfs_show_options(struct seq_file *m, struct dentry *root)
if (sbinfo->max_inodes != -1)
seq_printf(m, ",nr_inodes=%lu", sbinfo->max_inodes);
- hpage_size /= 1024;
+ hpage_size /= SZ_1K;
mod = 'K';
- if (hpage_size >= 1024) {
- hpage_size /= 1024;
+ if (hpage_size >= SZ_1K) {
+ hpage_size /= SZ_1K;
mod = 'M';
}
seq_printf(m, ",pagesize=%lu%c", hpage_size, mod);
--
2.31.0
Powered by blists - more mailing lists