[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20220917104311.1878250-1-yanaijie@huawei.com>
Date: Sat, 17 Sep 2022 18:43:04 +0800
From: Jason Yan <yanaijie@...wei.com>
To: <martin.petersen@...cle.com>, <jejb@...ux.ibm.com>
CC: <linux-scsi@...r.kernel.org>, <linux-kernel@...r.kernel.org>,
<hare@...e.com>, <hch@....de>, <bvanassche@....org>,
<john.garry@...wei.com>, <jinpu.wang@...ud.ionos.com>,
Jason Yan <yanaijie@...wei.com>
Subject: [PATCH 0/7] scsi: libsas: sas address comparation refactor
Sas address conversion and comparation is widely used in libsas and
drivers. However they are all opencoded and to avoid the line spill over
80 columns, are mostly split into multi-lines.
To make the code easier to read, introduce some helpers with clearer
semantics and replace the opencoded segments with them.
Jason Yan (7):
scsi: libsas: introduce sas address conversion and comparation helpers
scsi: libsas: use dev_and_phy_addr_same() instead of open coded
scsi: libsas: use ex_phy_addr_same() instead of open coded
scsi: libsas: use port_and_phy_addr_same() instead of open coded
scsi: hisi_sas: use dev_and_phy_addr_same() instead of open coded
scsi: pm8001: use dev_and_phy_addr_same() instead of open coded
scsi: mvsas: use dev_and_phy_addr_same() instead of open coded
drivers/scsi/hisi_sas/hisi_sas_main.c | 3 +--
drivers/scsi/libsas/sas_expander.c | 24 +++++++-------------
drivers/scsi/mvsas/mv_sas.c | 3 +--
drivers/scsi/pm8001/pm8001_sas.c | 3 +--
include/scsi/libsas.h | 32 +++++++++++++++++++++++++++
5 files changed, 43 insertions(+), 22 deletions(-)
--
2.31.1
Powered by blists - more mailing lists