lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Thu, 22 Sep 2022 22:39:20 +0000
From:   "Michael Kelley (LINUX)" <mikelley@...rosoft.com>
To:     Easwar Hariharan <eahariha@...ux.microsoft.com>,
        KY Srinivasan <kys@...rosoft.com>,
        Haiyang Zhang <haiyangz@...rosoft.com>,
        Stephen Hemminger <sthemmin@...rosoft.com>,
        "wei.liu@...nel.org" <wei.liu@...nel.org>,
        Dexuan Cui <decui@...rosoft.com>,
        "linux-hyperv@...r.kernel.org" <linux-hyperv@...r.kernel.org>,
        "linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>
Subject: RE: [PATCH] hv: Use PCI_VENDOR_ID_MICROSOFT for better
 discoverability

From: Easwar Hariharan <eahariha@...ux.microsoft.com> Sent: Monday, September 19, 2022 3:05 PM
> 
> pci_ids.h already defines PCI_VENDOR_ID_MICROSOFT, and is included via
> linux/pci.h. Use the define instead of the magic number.
> 
> Signed-off-by: Easwar Hariharan <easwar.hariharan@...rosoft.com>
> ---
>  drivers/hv/vmbus_drv.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/hv/vmbus_drv.c b/drivers/hv/vmbus_drv.c
> index 3c833ea..f2efb74 100644
> --- a/drivers/hv/vmbus_drv.c
> +++ b/drivers/hv/vmbus_drv.c
> @@ -2052,7 +2052,7 @@ struct hv_device *vmbus_device_create(const guid_t *type,
>  	child_device_obj->channel = channel;
>  	guid_copy(&child_device_obj->dev_type, type);
>  	guid_copy(&child_device_obj->dev_instance, instance);
> -	child_device_obj->vendor_id = 0x1414; /* MSFT vendor ID */
> +	child_device_obj->vendor_id = PCI_VENDOR_ID_MICROSOFT;
> 
>  	return child_device_obj;
>  }
> --
> 1.8.3.1

Reviewed-by: Michael Kelley <mikelley@...rosoft.com>

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ