[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <0280dfc4-1497-280a-f0cc-c2867227219b@digikod.net>
Date: Mon, 26 Sep 2022 12:44:26 +0200
From: Mickaël Salaün <mic@...ikod.net>
To: Jingyu Wang <jingyuwang_vip@....com>, paul@...l-moore.com,
jmorris@...ei.org, serge@...lyn.com
Cc: linux-security-module@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] landlock: Remove unnecessary conditionals
Thanks for the review. I agree that this condition is optional but it
makes the code less error prone, more consistent, easier to read, and
avoids jumping to an external function. I then don't think this minor
change is worth it.
On 08/09/2022 21:02, Jingyu Wang wrote:
> iput() has already handled null and non-null parameter, so it is no
> need to use if().
>
> Signed-off-by: Jingyu Wang <jingyuwang_vip@....com>
> ---
> security/landlock/fs.c | 3 +--
> 1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/security/landlock/fs.c b/security/landlock/fs.c
> index 6121e9834961..3d0a8a418ce4 100644
> --- a/security/landlock/fs.c
> +++ b/security/landlock/fs.c
> @@ -1009,8 +1009,7 @@ static void hook_sb_delete(struct super_block *const sb)
> spin_unlock(&sb->s_inode_list_lock);
>
> /* Puts the inode reference from the last loop walk, if any. */
> - if (prev_inode)
> - iput(prev_inode);
> + iput(prev_inode);
> /* Waits for pending iput() in release_inode(). */
> wait_var_event(&landlock_superblock(sb)->inode_refs,
> !atomic_long_read(&landlock_superblock(sb)->inode_refs));
>
> base-commit: 5957ac6635a1a12d4aa2661bbf04d3085a73372a
Powered by blists - more mailing lists