[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAL715W+gJKH+3xgFzUjPs6SAMwZCzkF5NNOTDpa4ov2qZ3r_iA@mail.gmail.com>
Date: Tue, 27 Sep 2022 10:48:52 -0700
From: Mingwei Zhang <mizhang@...gle.com>
To: Marc Zyngier <maz@...nel.org>
Cc: Oliver Upton <oliver.upton@...ux.dev>,
Catalin Marinas <catalin.marinas@....com>,
Will Deacon <will@...nel.org>,
James Morse <james.morse@....com>,
Alexandru Elisei <alexandru.elisei@....com>,
Suzuki K Poulose <suzuki.poulose@....com>,
Linux ARM <linux-arm-kernel@...ts.infradead.org>,
"moderated list:KERNEL VIRTUAL MACHINE FOR ARM64 (KVM/arm64)"
<kvmarm@...ts.cs.columbia.edu>, LKML <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH] KVM: arm64: Cleanup the __get_fault_info() to take out
the code that validates HPFAR
>
> Honestly, I'd refrain from such changes *unless* they enable something
> else. The current code is well understood by people hacking on it, and
> although I don't mind revamping it, it has to be for a good reason.
>
> I'd be much more receptive to such a change if it was a prefix to
> something that actually made a significant change.
>
> Thanks,
>
> M.
>
Hi Marc,
Thanks for the feedback. I am not sure about the style of the KVM ARM
side. But in general I think mixing the generic code for ARM and
specific CPU errata handling is misleading. For instance, in this
case:
+ if ((esr & ESR_ELx_FSC_TYPE) == FSC_PERM)
+ return false;
+
+ if (cpus_have_final_cap(ARM64_WORKAROUND_834220))
+ return false;
As shown it would be much cleaner to separate the two cases as the
former case is suggested in ARMv8 Spec D13.2.55. The latter case would
definitely come from a different source.
But I also don't have a strong opinion pushing this one. So, let me
pull it back then :)
Powered by blists - more mailing lists