lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:   Sat, 8 Oct 2022 16:51:05 +0200
From:   Borislav Petkov <bp@...en8.de>
To:     Ard Biesheuvel <ardb@...nel.org>
Cc:     linux-efi@...r.kernel.org, x86@...nel.org,
        linux-kernel@...r.kernel.org
Subject: Re: [PATCH] efi: x86: Make the deprecated EFI handover protocol
 optional

On Fri, Oct 07, 2022 at 07:29:18PM +0200, Ard Biesheuvel wrote:
> Given that loaders such as GRUB already carried the bootparams handling
> in order to implement non-EFI boot, retaining that code and just passing
> bootparams to the EFI stub was a reasonable choice (although defining an
> alternate entrypoint could have been avoided.) However, the GRUB side
> changes never made it upstream, and are only shipped by some of the
	  ^^^^^^^^^^^^^^^^^^^^^^^

> distros in their downstream versions.

Gotta love that bit particularly. :-(

> In the meantime, EFI support has been added to other Linux architecture
> ports, as well as to U-boot and systemd, including arch-agnostic methods
> for passing initrd images in memory [1], and for doing mixed mode boot
> [2], none of them requiring anything like the EFI handover protocol. So
> given that only out-of-tree distro GRUB relies on this, let's permit it
> to be omitted from the build, in preparation for retiring it completely
> at a later date. (Note that systemd-boot does have an implementation as
> well, but only uses it as a fallback for booting images that do not
> implement the LoadFile2 based initrd loading method, i.e., v5.8 or older)
> 
> [0] https://lore.kernel.org/all/20220927085842.2860715-1-ardb@kernel.org/
> [1] ec93fc371f01 ("efi/libstub: Add support for loading the initrd ...")
> [2] 97aa276579b2 ("efi/x86: Add true mixed mode entry point into ...")
> 
> Signed-off-by: Ard Biesheuvel <ardb@...nel.org>
> ---
>  arch/x86/Kconfig                   | 12 ++++++++++++
>  arch/x86/boot/compressed/head_64.S |  4 +++-
>  arch/x86/boot/header.S             |  2 +-
>  arch/x86/boot/tools/build.c        |  2 ++
>  4 files changed, 18 insertions(+), 2 deletions(-)
> 
> diff --git a/arch/x86/Kconfig b/arch/x86/Kconfig
> index f9920f1341c8..0c8fcb090232 100644
> --- a/arch/x86/Kconfig
> +++ b/arch/x86/Kconfig
> @@ -1964,6 +1964,18 @@ config EFI_STUB
>  
>  	  See Documentation/admin-guide/efi-stub.rst for more information.
>  
> +config EFI_HANDOVER_PROTOCOL
> +	bool "EFI handover protocol (DEPRECATED)"
> +	depends on EFI_STUB
> +	default y

I'd say "default n" here.

> +	help
> +	  Whether to include support for the deprecated EFI handover protocol,

"Select this in order to include..."

> +	  which defines alternative entry points into the EFI stub. This is a
> +	  practice that has no basis in the UEFI specification, and requires
> +	  a priori knowledge on the part of the bootloader about Linux/x86
> +	  specific ways of passing the command line and initrd, and where in
> +	  memory those assets may be loaded.

	"If in doubt, say N. This option and accompanying code will disappear
	in some future kernel as the corresponding GRUB support is not even
	present in upstream GRUB but only in some distros' versions."

> +
>  config EFI_MIXED
>  	bool "EFI mixed-mode support"
>  	depends on EFI_STUB && X86_64
> diff --git a/arch/x86/boot/compressed/head_64.S b/arch/x86/boot/compressed/head_64.S
> index 6ba2c2142c33..7bcc50c6cdcc 100644
> --- a/arch/x86/boot/compressed/head_64.S
> +++ b/arch/x86/boot/compressed/head_64.S
> @@ -286,7 +286,7 @@ SYM_FUNC_START(startup_32)
>  	lret
>  SYM_FUNC_END(startup_32)
>  
> -#ifdef CONFIG_EFI_MIXED
> +#if defined(CONFIG_EFI_MIXED) && defined(CONFIG_EFI_HANDOVER_PROTOCOL)

...

Can we use IS_ENABLED() in all that instead, in order to improve
readability?

In any case, looks good. I'm thinking I'll take it into tip after -rc1
and see who cries and why...

Thx.

-- 
Regards/Gruss,
    Boris.

https://people.kernel.org/tglx/notes-about-netiquette

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ