[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20221013022519epcms1p555f11b5f130e6991017dd76741ad583f@epcms1p5>
Date: Thu, 13 Oct 2022 11:25:19 +0900
From: MyungJoo Ham <myungjoo.ham@...sung.com>
To: Stephen Kitt <steve@....org>, Chanwoo Choi <cw00.choi@...sung.com>
CC: "linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>
Subject: RE: [PATCH] drivers/extcon: use simple i2c probe
>
> --------- Original Message ---------
> Sender : Stephen Kitt <steve@....org>
> Date : 2022-10-12 23:18 (GMT+9)
> Title : [PATCH] drivers/extcon: use simple i2c probe
>
> All these drivers have an i2c probe function which doesn't use the
> "struct i2c_device_id *id" parameter, so they can trivially be
> converted to the "probe_new" style of probe with a single argument.
>
> This is part of an ongoing transition to single-argument i2c probe
> functions. Old-style probe functions involve a call to i2c_match_id:
> in drivers/i2c/i2c-core-base.c,
>
> /*
> * When there are no more users of probe(),
> * rename probe_new to probe.
> */
> if (driver->probe_new)
> status = driver->probe_new(client);
> else if (driver->probe)
> status = driver->probe(client,
> i2c_match_id(driver->id_table, client));
> else
> status = -EINVAL;
>
> Drivers which don't need the second parameter can be declared using
> probe_new instead, avoiding the call to i2c_match_id. Drivers which do
> can still be converted to probe_new-style, calling i2c_match_id
> themselves (as is done currently for of_match_id).
>
> This change was done using the following Coccinelle script, and fixed
> up for whitespace changes:
>
> @ rule1 @
> identifier fn;
> identifier client, id;
> @@
>
> - static int fn(struct i2c_client *client, const struct i2c_device_id *id)
> + static int fn(struct i2c_client *client)
> {
> ...when != id
> }
>
> @ rule2 depends on rule1 @
> identifier rule1.fn;
> identifier driver;
> @@
>
> struct i2c_driver driver = {
> - .probe
> + .probe_new
> =
> (
> fn
> |
> - &fn
> + fn
> )
> ,
> };
>
> Signed-off-by: Stephen Kitt <steve@....org>
Acked-by: MyungJoo Ham <myungjoo.ham@...sung.com>
Chanwoo, PTAL.
Cheers,
MyungJoo
Powered by blists - more mailing lists