lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <a5c8533b-8d5a-2056-a449-cb347c031d92@acm.org>
Date:   Thu, 27 Oct 2022 14:05:11 -0700
From:   Bart Van Assche <bvanassche@....org>
To:     Asutosh Das <quic_asutoshd@...cinc.com>, quic_cang@...cinc.com,
        martin.petersen@...cle.com, linux-scsi@...r.kernel.org
Cc:     quic_nguyenb@...cinc.com, quic_xiaosenh@...cinc.com,
        stanley.chu@...iatek.com, eddie.huang@...iatek.com,
        daejun7.park@...sung.com, avri.altman@....com, mani@...nel.org,
        beanhuo@...ron.com, quic_richardp@...cinc.com,
        linux-arm-msm@...r.kernel.org,
        Alim Akhtar <alim.akhtar@...sung.com>,
        "James E.J. Bottomley" <jejb@...ux.ibm.com>,
        open list <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH v3 02/17] ufs: core: Optimize duplicate code to read
 extended feature

On 10/20/22 11:03, Asutosh Das wrote:
> The code to parse the extended feature is duplicated more then 2
> times in the ufs core. Replace the duplicated code with the
> function.
> 
> Signed-off-by: Asutosh Das <quic_asutoshd@...cinc.com>
> ---
>   drivers/ufs/core/ufshcd.c | 10 ++--------
>   1 file changed, 2 insertions(+), 8 deletions(-)
> 
> diff --git a/drivers/ufs/core/ufshcd.c b/drivers/ufs/core/ufshcd.c
> index 80f01d0..e2be3f4 100644
> --- a/drivers/ufs/core/ufshcd.c
> +++ b/drivers/ufs/core/ufshcd.c
> @@ -7605,13 +7605,7 @@ static void ufshcd_wb_probe(struct ufs_hba *hba, const u8 *desc_buf)
>   	     (hba->dev_quirks & UFS_DEVICE_QUIRK_SUPPORT_EXTENDED_FEATURES)))
>   		goto wb_disabled;
>   
> -	if (hba->desc_size[QUERY_DESC_IDN_DEVICE] <
> -	    DEVICE_DESC_PARAM_EXT_UFS_FEATURE_SUP + 4)
> -		goto wb_disabled;
> -
> -	ext_ufs_feature = get_unaligned_be32(desc_buf +
> -					DEVICE_DESC_PARAM_EXT_UFS_FEATURE_SUP);
> -
> +	ext_ufs_feature = ufs_get_ext_ufs_feature(hba, desc_buf);
>   	if (!(ext_ufs_feature & UFS_DEV_WRITE_BOOSTER_SUP))
>   		goto wb_disabled;
>   
> @@ -7665,7 +7659,7 @@ static void ufshcd_temp_notif_probe(struct ufs_hba *hba, const u8 *desc_buf)
>   	if (!(hba->caps & UFSHCD_CAP_TEMP_NOTIF) || dev_info->wspecversion < 0x300)
>   		return;
>   
> -	ext_ufs_feature = get_unaligned_be32(desc_buf + DEVICE_DESC_PARAM_EXT_UFS_FEATURE_SUP);
> +	ext_ufs_feature = ufs_get_ext_ufs_feature(hba, desc_buf);
>   
>   	if (ext_ufs_feature & UFS_DEV_LOW_TEMP_NOTIF)
>   		mask |= MASK_EE_TOO_LOW_TEMP;

Ah, that's the change I asked for in my reply to the previous patch :-)

Shouldn't patches 01/17 and 02/17 be reordered?

`git rebase -i` should make it easy to reorder these two patches.

Thanks,

Bart.

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ