[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <202211021233.02BF0D38@keescook>
Date: Wed, 2 Nov 2022 12:33:33 -0700
From: Kees Cook <keescook@...omium.org>
To: Rasmus Villemoes <rasmus.villemoes@...vas.dk>
Cc: Gwan-gyeong Mun <gwan-gyeong.mun@...el.com>,
luc.vanoostenryck@...il.com, nathan@...nel.org,
ndesaulniers@...gle.com, trix@...hat.com, dlatypov@...gle.com,
vitor@...saru.org, gustavoars@...nel.org,
linux-hardening@...r.kernel.org, llvm@...ts.linux.dev,
jani.nikula@...ux.intel.com, joonas.lahtinen@...ux.intel.com,
rodrigo.vivi@...el.com, tvrtko.ursulin@...ux.intel.com,
airlied@...ux.ie, daniel@...ll.ch, linux-kernel@...r.kernel.org,
intel-gfx@...ts.freedesktop.org, dri-devel@...ts.freedesktop.org,
linux-sparse@...r.kernel.org, arnd@...nel.org, mchehab@...nel.org,
mauro.chehab@...ux.intel.com
Subject: Re: [PATCH v5] overflow: Introduce overflows_type() and
castable_to_type()
On Wed, Nov 02, 2022 at 12:52:32PM +0100, Rasmus Villemoes wrote:
> On 24/10/2022 22.11, Gwan-gyeong Mun wrote:
> > From: Kees Cook <keescook@...omium.org>
> >
> > Implement a robust overflows_type() macro to test if a variable or
> > constant value would overflow another variable or type. This can be
> > used as a constant expression for static_assert() (which requires a
> > constant expression[1][2]) when used on constant values. This must be
> > constructed manually, since __builtin_add_overflow() does not produce
> > a constant expression[3].
> >
> > Additionally adds castable_to_type(), similar to __same_type(), but for
> > checking if a constant value would overflow if cast to a given type.
> >
>
> > +#define __overflows_type_constexpr(x, T) ( \
> > + is_unsigned_type(typeof(x)) ? \
> > + (x) > type_max(typeof(T)) ? 1 : 0 \
> > + : is_unsigned_type(typeof(T)) ? \
> > + (x) < 0 || (x) > type_max(typeof(T)) ? 1 : 0 \
> > + : (x) < type_min(typeof(T)) || \
> > + (x) > type_max(typeof(T)) ? 1 : 0)
> > +
>
> Can't all these instances of "foo ? 1 : 0" be simplified to "foo"? That
> would improve the readability of this thing somewhat IMO.
Oh, good point. :P I'll fix these.
--
Kees Cook
Powered by blists - more mailing lists