lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 2 Nov 2022 03:27:28 -0600
From:   Shuah Khan <skhan@...uxfoundation.org>
To:     Shaopeng Tan <tan.shaopeng@...fujitsu.com>,
        Fenghua Yu <fenghua.yu@...el.com>,
        Reinette Chatre <reinette.chatre@...el.com>,
        Shuah Khan <shuah@...nel.org>
Cc:     linux-kernel@...r.kernel.org, linux-kselftest@...r.kernel.org,
        Shuah Khan <skhan@...uxfoundation.org>
Subject: Re: [PATCH v3 2/5] selftests/resctrl: Return MBA check result and
 make it to output message

On 11/1/22 03:43, Shaopeng Tan wrote:
> Since MBA check result is not returned, the MBA test result message
> is always output as "ok" regardless of whether the MBA check result is
> true or false.
> 
> Make output message to be "not ok" if MBA check result is failed.
> 
> Reviewed-by: Reinette Chatre <reinette.chatre@...el.com>
> Signed-off-by: Shaopeng Tan <tan.shaopeng@...fujitsu.com>
> ---
>   tools/testing/selftests/resctrl/mba_test.c | 8 ++++----
>   1 file changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/tools/testing/selftests/resctrl/mba_test.c b/tools/testing/selftests/resctrl/mba_test.c
> index 1a1bdb6180cf..5d14802add4d 100644
> --- a/tools/testing/selftests/resctrl/mba_test.c
> +++ b/tools/testing/selftests/resctrl/mba_test.c
> @@ -51,7 +51,7 @@ static int mba_setup(int num, ...)
>   	return 0;
>   }
>   
> -static void show_mba_info(unsigned long *bw_imc, unsigned long *bw_resc)
> +static bool show_mba_info(unsigned long *bw_imc, unsigned long *bw_resc)
>   {
>   	int allocation, runs;
>   	bool failed = false;
> @@ -97,6 +97,8 @@ static void show_mba_info(unsigned long *bw_imc, unsigned long *bw_resc)
>   		       failed ? "Fail:" : "Pass:");
>   	if (failed)
>   		ksft_print_msg("At least one test failed\n");
> +
> +	return failed;

Rename "failed" to "ret" - naming the variable "failed" is confusing.

>   }
>   
>   static int check_results(void)
> @@ -132,9 +134,7 @@ static int check_results(void)
>   
>   	fclose(fp);
>   
> -	show_mba_info(bw_imc, bw_resc);
> -
> -	return 0;
> +	return show_mba_info(bw_imc, bw_resc);
>   }
>   
>   void mba_test_cleanup(void)

With that change,

Reviewed-by: Shuah Khan <skhan@...uxfoundation.org>

thanks,
-- Shuah

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ