[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <79c5d83f-27b2-dbe0-826b-bcb671e0766f@kernel.dk>
Date: Tue, 1 Nov 2022 20:25:27 -0600
From: Jens Axboe <axboe@...nel.dk>
To: Jinlong Chen <nickyc975@....edu.cn>, Christoph Hellwig <hch@....de>
Cc: linux-block@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 4/4] blk-mq: improve readability of blk_mq_alloc_request()
On 11/1/22 8:19 PM, Jinlong Chen wrote:
>> On Tue, Nov 01, 2022 at 11:11:37PM +0800, Jinlong Chen wrote:
>>> Add a helper blk_mq_alloc_request_nocache() to alloc request without
>>> cache. This makes blk_mq_alloc_request() more readable.
>>>
>>> Signed-off-by: Jinlong Chen <nickyc975@....edu.cn>
>>> ---
>>> block/blk-mq.c | 47 +++++++++++++++++++++++++++++------------------
>>> 1 file changed, 29 insertions(+), 18 deletions(-)
>>>
>>> diff --git a/block/blk-mq.c b/block/blk-mq.c
>>> index 87a6348a0d0a..2fae111a42c8 100644
>>> --- a/block/blk-mq.c
>>> +++ b/block/blk-mq.c
>>> @@ -572,36 +572,47 @@ static struct request *blk_mq_alloc_cached_request(struct request_queue *q,
>>> return rq;
>>> }
>>>
>>> +static struct request *blk_mq_alloc_request_nocache(struct request_queue *q,
>>> + blk_opf_t opf, blk_mq_req_flags_t flags)
>>
>> The name is a bit odd, but I can't think off a better one.
>>
>>> + struct blk_mq_alloc_data data = {
>>> .q = q,
>>> .flags = flags,
>>> .cmd_flags = opf,
>>> .nr_tags = 1,
>>> };
>>
>> And this now has superflous indenation. Overall, while the separate
>> helper looks marginally nicer, I'm not really sure it is worth the
>> churn.
>
> I'll drop the patch if you think it is not worth the churn. But I
> started doing this because of the following goto statement:
Please just drop it, I don't think it's an improvement.
--
Jens Axboe
Powered by blists - more mailing lists