lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Mon, 7 Nov 2022 17:48:51 -0800
From:   Vipin Sharma <vipinsh@...gle.com>
To:     David Matlack <dmatlack@...gle.com>
Cc:     seanjc@...gle.com, pbonzini@...hat.com, vkuznets@...hat.com,
        kvm@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 5/6] KVM: selftests: Move hypercall() to hyper.h

On Mon, Nov 7, 2022 at 10:30 AM David Matlack <dmatlack@...gle.com> wrote:
>
> On Fri, Nov 04, 2022 at 09:57:03PM -0700, Vipin Sharma wrote:
> > hypercall() can be used by other hyperv tests, move it to hyperv.h.
> >
> > Signed-off-by: Vipin Sharma <vipinsh@...gle.com>
> > ---
> >  .../selftests/kvm/include/x86_64/hyperv.h       | 17 +++++++++++++++++
> >  .../selftests/kvm/x86_64/hyperv_features.c      | 17 -----------------
> >  2 files changed, 17 insertions(+), 17 deletions(-)
> >
> > diff --git a/tools/testing/selftests/kvm/include/x86_64/hyperv.h b/tools/testing/selftests/kvm/include/x86_64/hyperv.h
> > index 9d8c325af1d9..87d8d9e444f7 100644
> > --- a/tools/testing/selftests/kvm/include/x86_64/hyperv.h
> > +++ b/tools/testing/selftests/kvm/include/x86_64/hyperv.h
> > @@ -199,4 +199,21 @@ static inline uint64_t hv_linux_guest_id(void)
> >              ((uint64_t)LINUX_VERSION_CODE << 16);
> >  }
> >
> > +static inline uint8_t hypercall(u64 control, vm_vaddr_t input_address,
> > +                             vm_vaddr_t output_address, uint64_t *hv_status)
> > +{
> > +     uint8_t vector;
> > +
> > +     /* Note both the hypercall and the "asm safe" clobber r9-r11. */
> > +     asm volatile("mov %[output_address], %%r8\n\t"
> > +                  KVM_ASM_SAFE("vmcall")
> > +                  : "=a" (*hv_status),
> > +                    "+c" (control), "+d" (input_address),
> > +                    KVM_ASM_SAFE_OUTPUTS(vector)
> > +                  : [output_address] "r"(output_address),
> > +                    "a" (-EFAULT)
> > +                  : "cc", "memory", "r8", KVM_ASM_SAFE_CLOBBERS);
> > +     return vector;
> > +}
>
> Since this function is Hyper-V specific it probably makes sense to
> rename it to hyperv_hypercall() as part of moving it to library, e.g. to
> differentiate it from kvm_hypercall().
>

Sounds good. Does it keeping it in header file "hyperv.h" seems fine
or should I create a new "hyperv.c" lib file and move function
definition there?

> > +
> >  #endif /* !SELFTEST_KVM_HYPERV_H */
> > diff --git a/tools/testing/selftests/kvm/x86_64/hyperv_features.c b/tools/testing/selftests/kvm/x86_64/hyperv_features.c
> > index b5a42cf1ad9d..31b22ee07dfb 100644
> > --- a/tools/testing/selftests/kvm/x86_64/hyperv_features.c
> > +++ b/tools/testing/selftests/kvm/x86_64/hyperv_features.c
> > @@ -13,23 +13,6 @@
> >  #include "processor.h"
> >  #include "hyperv.h"
> >
> > -static inline uint8_t hypercall(u64 control, vm_vaddr_t input_address,
> > -                             vm_vaddr_t output_address, uint64_t *hv_status)
> > -{
> > -     uint8_t vector;
> > -
> > -     /* Note both the hypercall and the "asm safe" clobber r9-r11. */
> > -     asm volatile("mov %[output_address], %%r8\n\t"
> > -                  KVM_ASM_SAFE("vmcall")
> > -                  : "=a" (*hv_status),
> > -                    "+c" (control), "+d" (input_address),
> > -                    KVM_ASM_SAFE_OUTPUTS(vector)
> > -                  : [output_address] "r"(output_address),
> > -                    "a" (-EFAULT)
> > -                  : "cc", "memory", "r8", KVM_ASM_SAFE_CLOBBERS);
> > -     return vector;
> > -}
> > -
> >  struct msr_data {
> >       uint32_t idx;
> >       bool available;
> > --
> > 2.38.1.273.g43a17bfeac-goog
> >

Powered by blists - more mailing lists