[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <3225614.44csPzL39Z@kreacher>
Date: Wed, 09 Nov 2022 13:12:00 +0100
From: "Rafael J. Wysocki" <rjw@...ysocki.net>
To: Alexandre Belloni <alexandre.belloni@...tlin.com>,
linux-rtc@...r.kernel.org
Cc: Linux ACPI <linux-acpi@...r.kernel.org>,
LKML <linux-kernel@...r.kernel.org>,
Linux PM <linux-pm@...r.kernel.org>,
Zhang Rui <rui.zhang@...el.com>,
Alessandro Zummo <a.zummo@...ertech.it>,
Andy Shevchenko <andriy.shevchenko@...ux.intel.com>,
Bjorn Helgaas <helgaas@...nel.org>
Subject: [PATCH v2 4/5] rtc: rtc-cmos: Rename ACPI-related functions
From: Rafael J. Wysocki <rafael.j.wysocki@...el.com>
The names of rtc_wake_setup() and cmos_wake_setup() don't indicate
that these functions are ACPI-related, which is the case, and the
former doesn't really reflect the role of the function.
Rename them to acpi_rtc_event_setup() and acpi_cmos_wake_setup(),
respectively, to address this shortcoming.
No intentional functional impact.
Signed-off-by: Rafael J. Wysocki <rafael.j.wysocki@...el.com>
---
v1 -> v2:
* Use acpi_cmos_wake_setup() as the new name instead of
cmos_acpi_wake_setup() (Andy)
---
drivers/rtc/rtc-cmos.c | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)
Index: linux-pm/drivers/rtc/rtc-cmos.c
===================================================================
--- linux-pm.orig/drivers/rtc/rtc-cmos.c
+++ linux-pm/drivers/rtc/rtc-cmos.c
@@ -784,7 +784,7 @@ static u32 rtc_handler(void *context)
return ACPI_INTERRUPT_HANDLED;
}
-static void rtc_wake_setup(struct device *dev)
+static void acpi_rtc_event_setup(struct device *dev)
{
if (acpi_disabled)
return;
@@ -828,7 +828,7 @@ static void use_acpi_alarm_quirks(void)
static inline void use_acpi_alarm_quirks(void) { }
#endif
-static void cmos_wake_setup(struct device *dev)
+static void acpi_cmos_wake_setup(struct device *dev)
{
if (acpi_disabled)
return;
@@ -880,11 +880,11 @@ static void cmos_check_acpi_rtc_status(s
#else /* !CONFIG_ACPI */
-static inline void rtc_wake_setup(struct device *dev)
+static inline void acpi_rtc_event_setup(struct device *dev)
{
}
-static inline void cmos_wake_setup(struct device *dev)
+static inline void acpi_cmos_wake_setup(struct device *dev)
{
}
@@ -986,7 +986,7 @@ cmos_do_probe(struct device *dev, struct
cmos_rtc.wake_off = info->wake_off;
}
} else {
- cmos_wake_setup(dev);
+ acpi_cmos_wake_setup(dev);
}
if (cmos_rtc.day_alrm >= 128)
@@ -1091,7 +1091,7 @@ cmos_do_probe(struct device *dev, struct
* the ACPI RTC fixed event.
*/
if (!info)
- rtc_wake_setup(dev);
+ acpi_rtc_event_setup(dev);
dev_info(dev, "%s%s, %d bytes nvram%s\n",
!is_valid_irq(rtc_irq) ? "no alarms" :
Powered by blists - more mailing lists