[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <Y2z7lLEvQx7iLuuP@alley>
Date: Thu, 10 Nov 2022 14:24:36 +0100
From: Petr Mladek <pmladek@...e.com>
To: Geert Uytterhoeven <geert@...ux-m68k.org>
Cc: John Ogness <john.ogness@...utronix.de>,
Sergey Senozhatsky <senozhatsky@...omium.org>,
Steven Rostedt <rostedt@...dmis.org>,
Thomas Gleixner <tglx@...utronix.de>,
linux-kernel@...r.kernel.org,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
Jiri Slaby <jirislaby@...nel.org>,
Andy Shevchenko <andriy.shevchenko@...ux.intel.com>,
Ilpo Järvinen <ilpo.jarvinen@...ux.intel.com>,
Geert Uytterhoeven <geert+renesas@...der.be>,
Tony Lindgren <tony@...mide.com>,
Lukas Wunner <lukas@...ner.de>, linux-serial@...r.kernel.org
Subject: Re: [PATCH printk v3 23/40] serial_core: replace
uart_console_enabled() with uart_console_registered()
On Tue 2022-11-08 09:46:20, Geert Uytterhoeven wrote:
> Hi John,
>
> On Mon, Nov 7, 2022 at 3:16 PM John Ogness <john.ogness@...utronix.de> wrote:
> > All users of uart_console_enabled() really want to know if a console
> > is registered. It is not reliable to check for CON_ENABLED in order
> > to identify if a console is registered. Use console_is_registered()
> > instead.
> >
> > A _locked() variant is provided because uart_set_options() is always
> > called with the console_list_lock held and must check if a console
> > is registered in order to synchronize with kgdboc.
> >
> > Signed-off-by: John Ogness <john.ogness@...utronix.de>
>
> > --- a/include/linux/serial_core.h
> > +++ b/include/linux/serial_core.h
> > @@ -743,9 +743,20 @@ static const bool earlycon_acpi_spcr_enable EARLYCON_USED_OR_UNUSED;
> > static inline int setup_earlycon(char *buf) { return 0; }
> > #endif
> >
> > -static inline bool uart_console_enabled(struct uart_port *port)
> > +/* Variant of uart_console_registered() when the console_list_lock is held. */
> > +static inline bool uart_console_registered_locked(struct uart_port *port)
> > {
> > - return uart_console(port) && (port->cons->flags & CON_ENABLED);
> > + return uart_console(port) && console_is_registered_locked(port->cons);
> > +}
> > +
> > +static inline bool uart_console_registered(struct uart_port *port)
> > +{
> > + bool ret;
> > +
> > + console_list_lock();
> > + ret = uart_console_registered_locked(port);
> > + console_list_unlock();
> > + return ret;
>
> Perhaps
>
> return uart_console(port) && console_is_registered();
>
> to avoid locking the list when the first condition is not true?
I do not have strong opinion on this. It is true that the code
duplication is trivial but it is a code duplication. Either
way would work for me.
The reset of the code looks good. Feel free to use:
Reviewed-by: Petr Mladek <pmladek@...e.com>
Best Regards,
Petr
Powered by blists - more mailing lists