lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Sat, 12 Nov 2022 11:48:55 +0800
From:   Xu Kuohai <xukuohai@...wei.com>
To:     Andrii Nakryiko <andrii.nakryiko@...il.com>
CC:     wuqiang <wuqiang.matt@...edance.com>, <bpf@...r.kernel.org>,
        <linux-kernel@...r.kernel.org>,
        Alexei Starovoitov <ast@...nel.org>,
        Daniel Borkmann <daniel@...earbox.net>,
        Andrii Nakryiko <andrii@...nel.org>,
        Martin KaFai Lau <martin.lau@...ux.dev>,
        Song Liu <song@...nel.org>, Yonghong Song <yhs@...com>,
        John Fastabend <john.fastabend@...il.com>,
        KP Singh <kpsingh@...nel.org>,
        Stanislav Fomichev <sdf@...gle.com>,
        Hao Luo <haoluo@...gle.com>, Jiri Olsa <jolsa@...nel.org>
Subject: Re: [PATCH bpf-next v4] bpf: Initialize same number of free nodes for
 each pcpu_freelist

On 11/12/2022 4:12 AM, Andrii Nakryiko wrote:
> On Thu, Nov 10, 2022 at 11:00 PM Xu Kuohai <xukuohai@...wei.com> wrote:
>>
>> On 11/11/2022 11:53 AM, wuqiang wrote:
>>> On 2022/11/10 20:21, Xu Kuohai wrote:
>>>> pcpu_freelist_populate() initializes nr_elems / num_possible_cpus() + 1
>>>> free nodes for some CPUs, and then possibly one CPU with fewer nodes,
>>>> followed by remaining cpus with 0 nodes. For example, when nr_elems == 256
>>>> and num_possible_cpus() == 32, CPU 0~27 each gets 9 free nodes, CPU 28 gets
>>>> 4 free nodes, CPU 29~31 get 0 free nodes, while in fact each CPU should get
>>>> 8 nodes equally.
>>>>
>>>> This patch initializes nr_elems / num_possible_cpus() free nodes for each
>>>> CPU firstly, then allocates the remaining free nodes by one for each CPU
>>>> until no free nodes left.
>>>>
>>>> Signed-off-by: Xu Kuohai <xukuohai@...wei.com>
>>>> Acked-by: Yonghong Song <yhs@...com>
>>>> ---
>>>> v4: Remove unneeded min()
>>>> v3: Simplify code as suggested by Andrii
>>>> v2: Update commit message and add Yonghong's ack
>>>> ---
>>>>    kernel/bpf/percpu_freelist.c | 26 +++++++++++++-------------
>>>>    1 file changed, 13 insertions(+), 13 deletions(-)
>>>>
>>>> diff --git a/kernel/bpf/percpu_freelist.c b/kernel/bpf/percpu_freelist.c
>>>> index b6e7f5c5b9ab..27f2c4aff623 100644
>>>> --- a/kernel/bpf/percpu_freelist.c
>>>> +++ b/kernel/bpf/percpu_freelist.c
>>>> @@ -100,22 +100,22 @@ void pcpu_freelist_populate(struct pcpu_freelist *s, void *buf, u32 elem_size,
>>>>                    u32 nr_elems)
>>>>    {
>>>>        struct pcpu_freelist_head *head;
>>>> -    int i, cpu, pcpu_entries;
>>>> +    unsigned int cpu, cpu_idx, i, j, n, m;
>>>> -    pcpu_entries = nr_elems / num_possible_cpus() + 1;
>>>> -    i = 0;
>>>> +    n = nr_elems / num_possible_cpus();
>>>> +    m = nr_elems % num_possible_cpus();
>>>> +
>>>> +    cpu_idx = 0;
>>>>        for_each_possible_cpu(cpu) {
>>>> -again:
>>>> -        head = per_cpu_ptr(s->freelist, cpu);
>>>> -        /* No locking required as this is not visible yet. */
>>>> -        pcpu_freelist_push_node(head, buf);
>>>> -        i++;
>>>> -        buf += elem_size;
>>>> -        if (i == nr_elems)
>>>> -            break;
>>>> -        if (i % pcpu_entries)
>>>> -            goto again;
>>>> +        j = n + (cpu_idx < m ? 1 : 0);
>>>> +        for (i = 0; i < j; i++) {
>>>> +            head = per_cpu_ptr(s->freelist, cpu);
>>>
>>> Better move it out of "i-loop",
>>
>> OK, will do
>>
> 
> I did that while applying. Also added
> 
> Fixes: e19494edab82 ("bpf: introduce percpu_freelist")
> 
> Please don't forget to add Fixes tag for future patches.
>

OK, thanks for the kind reminder

> Applied to bpf tree.
> 
>>> and rename "j" to a meaningful name to avoid
>>> possible misuse.
>>>
>> The loop is short enough to be readable and "j" is not used elsewhere, so I
>> think it's good to keep the name simple.
>>
>>>> +            /* No locking required as this is not visible yet. */
>>>> +            pcpu_freelist_push_node(head, buf);
>>>> +            buf += elem_size;
>>>> +        }
>>>> +        cpu_idx++;
>>>>        }
>>>>    }
>>>
>>> .
>>
> .

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ