lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 15 Nov 2022 15:35:48 +0200
From:   Andy Shevchenko <andriy.shevchenko@...ux.intel.com>
To:     Rasmus Villemoes <linux@...musvillemoes.dk>
Cc:     Jonathan Cameron <jic23@...nel.org>,
        Lars-Peter Clausen <lars@...afoo.de>,
        Javier Arteaga <javier@...tex.com>,
        Dan O'Donovan <dan@...tex.com>,
        Nicola Lunghi <nicola.lunghi@...tex.com>,
        Jonathan Cameron <Jonathan.Cameron@...wei.com>,
        linux-iio@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] iio: adc128s052: add proper .data members in
 adc128_of_match table

On Tue, Nov 15, 2022 at 02:23:23PM +0100, Rasmus Villemoes wrote:
> Prior to commit bd5d54e4d49d ("iio: adc128s052: add ACPI _HID
> AANT1280"), the driver unconditionally used spi_get_device_id() to get
> the index into the adc128_config array.
> 
> However, with that commit, OF-based boards now incorrectly treat all
> supported sensors as if they are an adc128s052, because all the .data
> members of the adc128_of_match table are implicitly 0. Our board,
> which has an adc122s021, thus exposes 8 channels whereas it really
> only has two.
> 
> Fixes: bd5d54e4d49d ("iio: adc128s052: add ACPI _HID AANT1280")
> Signed-off-by: Rasmus Villemoes <linux@...musvillemoes.dk>
> ---
> 
> I think the driver could be simplified somewhat by having just one
> single adc_channels[] array with the 8 entries, unconditionally use
> that as ->channels, with ->num_channels being taken from the match
> data instead of having this indirection through the auxiliary config
> array.

Hmm... I have a patch locally that changes this to take pointers instead of
numbers and using spi_get_device_match_data() (but the latter is only available
in Linux Next so far).

> But this patch is properly more suited for -stable.

LGTM for time being
Reviewed-by: Andy Shevchenko <andriy.shevchenko@...ux.intel.com>

>  drivers/iio/adc/ti-adc128s052.c | 14 +++++++-------
>  1 file changed, 7 insertions(+), 7 deletions(-)
> 
> diff --git a/drivers/iio/adc/ti-adc128s052.c b/drivers/iio/adc/ti-adc128s052.c
> index 622fd384983c..b3d5b9b7255b 100644
> --- a/drivers/iio/adc/ti-adc128s052.c
> +++ b/drivers/iio/adc/ti-adc128s052.c
> @@ -181,13 +181,13 @@ static int adc128_probe(struct spi_device *spi)
>  }
>  
>  static const struct of_device_id adc128_of_match[] = {
> -	{ .compatible = "ti,adc128s052", },
> -	{ .compatible = "ti,adc122s021", },
> -	{ .compatible = "ti,adc122s051", },
> -	{ .compatible = "ti,adc122s101", },
> -	{ .compatible = "ti,adc124s021", },
> -	{ .compatible = "ti,adc124s051", },
> -	{ .compatible = "ti,adc124s101", },
> +	{ .compatible = "ti,adc128s052", .data = (void*)0L, },
> +	{ .compatible = "ti,adc122s021", .data = (void*)1L, },
> +	{ .compatible = "ti,adc122s051", .data = (void*)1L, },
> +	{ .compatible = "ti,adc122s101", .data = (void*)1L, },
> +	{ .compatible = "ti,adc124s021", .data = (void*)2L, },
> +	{ .compatible = "ti,adc124s051", .data = (void*)2L, },
> +	{ .compatible = "ti,adc124s101", .data = (void*)2L, },
>  	{ /* sentinel */ },
>  };
>  MODULE_DEVICE_TABLE(of, adc128_of_match);
> -- 
> 2.37.2
> 

-- 
With Best Regards,
Andy Shevchenko


Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ