[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <CAJZ5v0ivJXmkW8eogRrNekkTP67UJY6kcp1QYJNuSHv+qdOzhQ@mail.gmail.com>
Date: Tue, 29 Nov 2022 18:54:50 +0100
From: "Rafael J. Wysocki" <rafael@...nel.org>
To: ye.xingchen@....com.cn
Cc: rafael@...nel.org, lenb@...nel.org, linux-acpi@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH] ACPI: PAD: use sysfs_emit() to instead of scnprintf()
On Tue, Nov 29, 2022 at 12:32 PM <ye.xingchen@....com.cn> wrote:
>
> From: ye xingchen <ye.xingchen@....com.cn>
>
> Replace the open-code with sysfs_emit() to simplify the code.
>
> Signed-off-by: ye xingchen <ye.xingchen@....com.cn>
Can you please send one combo patch for this for all of the affected
code in drivers/acpi/?
> ---
> drivers/acpi/acpi_pad.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/acpi/acpi_pad.c b/drivers/acpi/acpi_pad.c
> index edbb28faee2a..02f1a1b1143c 100644
> --- a/drivers/acpi/acpi_pad.c
> +++ b/drivers/acpi/acpi_pad.c
> @@ -287,7 +287,7 @@ static ssize_t rrtime_store(struct device *dev,
> static ssize_t rrtime_show(struct device *dev,
> struct device_attribute *attr, char *buf)
> {
> - return scnprintf(buf, PAGE_SIZE, "%d\n", round_robin_time);
> + return sysfs_emit(buf, "%d\n", round_robin_time);
> }
> static DEVICE_ATTR_RW(rrtime);
>
> @@ -309,7 +309,7 @@ static ssize_t idlepct_store(struct device *dev,
> static ssize_t idlepct_show(struct device *dev,
> struct device_attribute *attr, char *buf)
> {
> - return scnprintf(buf, PAGE_SIZE, "%d\n", idle_pct);
> + return sysfs_emit(buf, "%d\n", idle_pct);
> }
> static DEVICE_ATTR_RW(idlepct);
>
> --
> 2.25.1
Powered by blists - more mailing lists