lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Thu, 1 Dec 2022 10:50:01 -0600
From:   Jeff LaBundy <jeff@...undy.com>
To:     ye.xingchen@....com.cn
Cc:     dmitry.torokhov@...il.com, colin.i.king@...il.com,
        linux-input@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] Input: misc: use sysfs_emit() to instead of scnprintf()

Hi Ye,

On Thu, Dec 01, 2022 at 03:48:38PM +0800, ye.xingchen@....com.cn wrote:
> From: ye xingchen <ye.xingchen@....com.cn>
> 
> Replace the open-code with sysfs_emit() to simplify the code.
> 
> Signed-off-by: ye xingchen <ye.xingchen@....com.cn>
> ---
>  drivers/input/misc/ims-pcu.c | 10 +++++-----
>  drivers/input/misc/iqs269a.c | 18 +++++++++---------
>  2 files changed, 14 insertions(+), 14 deletions(-)
> 
> diff --git a/drivers/input/misc/ims-pcu.c b/drivers/input/misc/ims-pcu.c
> index b2f1292e27ef..6e8cc28debd9 100644
> --- a/drivers/input/misc/ims-pcu.c
> +++ b/drivers/input/misc/ims-pcu.c
> @@ -1050,7 +1050,7 @@ static ssize_t ims_pcu_attribute_show(struct device *dev,
>  			container_of(dattr, struct ims_pcu_attribute, dattr);
>  	char *field = (char *)pcu + attr->field_offset;
> 
> -	return scnprintf(buf, PAGE_SIZE, "%.*s\n", attr->field_length, field);
> +	return sysfs_emit(buf, "%.*s\n", attr->field_length, field);
>  }
> 
>  static ssize_t ims_pcu_attribute_store(struct device *dev,
> @@ -1206,7 +1206,7 @@ ims_pcu_update_firmware_status_show(struct device *dev,
>  	struct usb_interface *intf = to_usb_interface(dev);
>  	struct ims_pcu *pcu = usb_get_intfdata(intf);
> 
> -	return scnprintf(buf, PAGE_SIZE, "%d\n", pcu->update_firmware_status);
> +	return sysfs_emit(buf, "%d\n", pcu->update_firmware_status);
>  }
> 
>  static DEVICE_ATTR(update_firmware_status, S_IRUGO,
> @@ -1309,7 +1309,7 @@ static ssize_t ims_pcu_ofn_reg_data_show(struct device *dev,
>  	if (error)
>  		return error;
> 
> -	return scnprintf(buf, PAGE_SIZE, "%x\n", data);
> +	return sysfs_emit(buf, "%x\n", data);
>  }
> 
>  static ssize_t ims_pcu_ofn_reg_data_store(struct device *dev,
> @@ -1344,7 +1344,7 @@ static ssize_t ims_pcu_ofn_reg_addr_show(struct device *dev,
>  	int error;
> 
>  	mutex_lock(&pcu->cmd_mutex);
> -	error = scnprintf(buf, PAGE_SIZE, "%x\n", pcu->ofn_reg_addr);
> +	error = sysfs_emit(buf, "%x\n", pcu->ofn_reg_addr);
>  	mutex_unlock(&pcu->cmd_mutex);
> 
>  	return error;
> @@ -1397,7 +1397,7 @@ static ssize_t ims_pcu_ofn_bit_show(struct device *dev,
>  	if (error)
>  		return error;
> 
> -	return scnprintf(buf, PAGE_SIZE, "%d\n", !!(data & (1 << attr->nr)));
> +	return sysfs_emit(buf, "%d\n", !!(data & (1 << attr->nr)));
>  }
> 
>  static ssize_t ims_pcu_ofn_bit_store(struct device *dev,
> diff --git a/drivers/input/misc/iqs269a.c b/drivers/input/misc/iqs269a.c
> index a348247d3d38..e4d5cea51f39 100644
> --- a/drivers/input/misc/iqs269a.c
> +++ b/drivers/input/misc/iqs269a.c
> @@ -1332,7 +1332,7 @@ static ssize_t counts_show(struct device *dev,
>  	if (error)
>  		return error;
> 
> -	return scnprintf(buf, PAGE_SIZE, "%u\n", le16_to_cpu(counts));
> +	return sysfs_emit(buf, "%u\n", le16_to_cpu(counts));
>  }
> 
>  static ssize_t hall_bin_show(struct device *dev,
> @@ -1369,7 +1369,7 @@ static ssize_t hall_bin_show(struct device *dev,
>  		return -EINVAL;
>  	}
> 
> -	return scnprintf(buf, PAGE_SIZE, "%u\n", val);
> +	return sysfs_emit(buf, "%u\n", val);
>  }
> 
>  static ssize_t hall_enable_show(struct device *dev,
> @@ -1377,7 +1377,7 @@ static ssize_t hall_enable_show(struct device *dev,
>  {
>  	struct iqs269_private *iqs269 = dev_get_drvdata(dev);
> 
> -	return scnprintf(buf, PAGE_SIZE, "%u\n", iqs269->hall_enable);
> +	return sysfs_emit(buf, "%u\n", iqs269->hall_enable);
>  }
> 
>  static ssize_t hall_enable_store(struct device *dev,
> @@ -1407,7 +1407,7 @@ static ssize_t ch_number_show(struct device *dev,
>  {
>  	struct iqs269_private *iqs269 = dev_get_drvdata(dev);
> 
> -	return scnprintf(buf, PAGE_SIZE, "%u\n", iqs269->ch_num);
> +	return sysfs_emit(buf, "%u\n", iqs269->ch_num);
>  }
> 
>  static ssize_t ch_number_store(struct device *dev,
> @@ -1435,7 +1435,7 @@ static ssize_t rx_enable_show(struct device *dev,
>  {
>  	struct iqs269_private *iqs269 = dev_get_drvdata(dev);
> 
> -	return scnprintf(buf, PAGE_SIZE, "%u\n",
> +	return sysfs_emit(buf, "%u\n",
>  			 iqs269->ch_reg[iqs269->ch_num].rx_enable);

Please refer to my earlier comment with regard to vertical alignment.

>  }
> 
> @@ -1475,7 +1475,7 @@ static ssize_t ati_mode_show(struct device *dev,
>  	if (error)
>  		return error;
> 
> -	return scnprintf(buf, PAGE_SIZE, "%u\n", val);
> +	return sysfs_emit(buf, "%u\n", val);
>  }
> 
>  static ssize_t ati_mode_store(struct device *dev,
> @@ -1508,7 +1508,7 @@ static ssize_t ati_base_show(struct device *dev,
>  	if (error)
>  		return error;
> 
> -	return scnprintf(buf, PAGE_SIZE, "%u\n", val);
> +	return sysfs_emit(buf, "%u\n", val);
>  }
> 
>  static ssize_t ati_base_store(struct device *dev,
> @@ -1541,7 +1541,7 @@ static ssize_t ati_target_show(struct device *dev,
>  	if (error)
>  		return error;
> 
> -	return scnprintf(buf, PAGE_SIZE, "%u\n", val);
> +	return sysfs_emit(buf, "%u\n", val);
>  }
> 
>  static ssize_t ati_target_store(struct device *dev,
> @@ -1568,7 +1568,7 @@ static ssize_t ati_trigger_show(struct device *dev,
>  {
>  	struct iqs269_private *iqs269 = dev_get_drvdata(dev);
> 
> -	return scnprintf(buf, PAGE_SIZE, "%u\n", iqs269->ati_current);
> +	return sysfs_emit(buf, "%u\n", iqs269->ati_current);

This patch creates a merge conflict with another one I have out for
review [1], so one of us will need to rework.

My hope is that I can go first, because mine is a bug fix and hence
higher priority.

>  }
> 
>  static ssize_t ati_trigger_store(struct device *dev,
> -- 
> 2.25.1

[1] https://patchwork.kernel.org/patch/13058161/

Kind regards,
Jeff LaBundy

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ