[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <Y5No5kMNGGJkmcPn@slm.duckdns.org>
Date: Fri, 9 Dec 2022 06:57:10 -1000
From: Tejun Heo <tj@...nel.org>
To: Li Lingfeng <lilingfeng3@...wei.com>
Cc: linux-kernel@...r.kernel.org, jack@...e.cz, bingjingc@...ology.com,
ebiggers@...gle.com, james.smart@...adcom.com, houtao1@...wei.com,
yi.zhang@...wei.com, yangerkun@...wei.com, yukuai3@...wei.com
Subject: Re: [PATCH-next] lib: parser: optimize match_NUMER apis to use local
array
Hello,
In general, I think this is a great idea. Some nits below:
On Fri, Dec 09, 2022 at 02:34:34PM +0800, Li Lingfeng wrote:
> +/*
> + * max size needed by diffrent bases to express U64
> + * HEX: "0xFFFFFFFFFFFFFFFF" --> 18
> + * DEC: "18446744073709551615" --> 20
> + * OCT: "01777777777777777777777" --> 23
> + * pick the max one to define U64_MAX_SIZE
> + */
> +#define U64_MAX_SIZE 23
Bikeshedding but how about naming it like NUMBER_BUF_LEN and including the
space for '\0'? Or just give it some extra space and make it 32 bytes.
> +static int match_strdup_local(const substring_t *s, char *buf)
I find it weird to name this as generic as match_strdup_local() and make it
assume that the buffer length is U64_MAX_SIZE + 1. Maybe just let the caller
pass in the buffer length as a parameter? Then, it's just strcpy and there
already is match_strlcpy() so we don't need this at all.
> +{
> + size_t len = s->to - s->from;
> +
> + if (!s->from)
> + return -EINVAL;
If we use match_strlcpy() we lose the above null check but given that other
match_*() functions aren't doing it, this likely shouldn't matter.
Thanks.
--
tejun
Powered by blists - more mailing lists