lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Sun, 11 Dec 2022 12:10:26 +0000
From:   Jonathan Cameron <jic23@...nel.org>
To:     <ye.xingchen@....com.cn>
Cc:     <lars@...afoo.de>, <andriy.shevchenko@...ux.intel.com>,
        <linux-iio@...r.kernel.org>, <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH] iio: health: afe440x: Convert to use sysfs_emit_at()
 API

On Wed, 7 Dec 2022 15:37:40 +0800 (CST)
<ye.xingchen@....com.cn> wrote:

> From: ye xingchen <ye.xingchen@....com.cn>
> 
> Follow the advice of the Documentation/filesystems/sysfs.rst and show()
> should only use sysfs_emit() or sysfs_emit_at() when formatting the
> value to be returned to user space.
> 
> Signed-off-by: ye xingchen <ye.xingchen@....com.cn>
> ---
>  drivers/iio/health/afe440x.h | 4 +---
>  1 file changed, 1 insertion(+), 3 deletions(-)
> 
> diff --git a/drivers/iio/health/afe440x.h b/drivers/iio/health/afe440x.h
> index 0adea0047eba..7750b1adc423 100644
> --- a/drivers/iio/health/afe440x.h
> +++ b/drivers/iio/health/afe440x.h
> @@ -122,9 +122,7 @@ static ssize_t _name ## _show(struct device *dev,			\
>  	int i;								\
>  									\
>  	for (i = 0; i < ARRAY_SIZE(_table); i++)			\
> -		len += scnprintf(buf + len, PAGE_SIZE - len, "%d.%06u ", \
> -				 _table[i].integer,			\
> -				 _table[i].fract);			\
> +		len += sysfs_emit_at(buf, len, "%d.%06u ", _table[i].integer, _table[i].fract); \
Please keep to the shorter original wrapping on this.
It's fine to go above 80 chars (below 100) if it makes a significant improvement
to readability.  I don't think that's true here, so better to stick to the shorter length.

>  									\
>  	buf[len - 1] = '\n';						\
>  									\

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ