[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <Y6HtH0RWNYc1gT2+@smile.fi.intel.com>
Date: Tue, 20 Dec 2022 19:13:03 +0200
From: Andy Shevchenko <andriy.shevchenko@...ux.intel.com>
To: Hanna Hawa <hhhawa@...zon.com>
Cc: wsa@...nel.org, jarkko.nikula@...ux.intel.com,
mika.westerberg@...ux.intel.com, jsd@...ihalf.com,
linus.walleij@...aro.org, ben-linux@...ff.org,
linux-i2c@...r.kernel.org, linux-kernel@...r.kernel.org,
dwmw@...zon.co.uk, benh@...zon.com, ronenk@...zon.com,
talel@...zon.com, jonnyc@...zon.com, hanochu@...zon.com,
farbere@...zon.com, itamark@...zon.com,
Lareine Khawaly <lareine@...zon.com>
Subject: Re: [PATCH v4 1/1] i2c: designware: use casting of u64 in clock
multiplication to avoid overflow
On Tue, Dec 20, 2022 at 07:11:51PM +0200, Andy Shevchenko wrote:
> On Tue, Dec 20, 2022 at 04:48:06PM +0000, Hanna Hawa wrote:
...
> > - return DIV_ROUND_CLOSEST(ic_clk * tSYMBOL, MICRO) - 8 + offset;
> > + return DIV_ROUND_CLOSEST_ULL((u64)ic_clk * tSYMBOL, MICRO) - 8 +
> > + offset;
>
> Broken indentation.
>
> ...
>
> > - return DIV_ROUND_CLOSEST(ic_clk * (tSYMBOL + tf), MICRO) - 3 + offset;
> > + return DIV_ROUND_CLOSEST_ULL((u64)ic_clk * (tSYMBOL + tf),
> > + MICRO) - 3 + offset;
>
> I would still go with 'MICRO) -' part to be on the previous line despite being
> over 80, this is logical split which increases readability.
>
> > - return DIV_ROUND_CLOSEST(ic_clk * (tLOW + tf), MICRO) - 1 + offset;
> > + return DIV_ROUND_CLOSEST_ULL((u64)ic_clk * (tLOW + tf), MICRO) - 1 +
> > + offset;
>
> Broken indentation.
That said, can you just follow what I have said in a review of v3?
--
With Best Regards,
Andy Shevchenko
Powered by blists - more mailing lists