[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <a03fb002-ef66-e9ea-7447-baf3d3aff1d9@redhat.com>
Date: Sat, 24 Dec 2022 10:12:09 +0100
From: Paolo Bonzini <pbonzini@...hat.com>
To: Sean Christopherson <seanjc@...gle.com>,
Marc Zyngier <maz@...nel.org>,
Paul Walmsley <paul.walmsley@...ive.com>,
Palmer Dabbelt <palmer@...belt.com>,
Albert Ou <aou@...s.berkeley.edu>,
Nathan Chancellor <nathan@...nel.org>,
Nick Desaulniers <ndesaulniers@...gle.com>
Cc: James Morse <james.morse@....com>,
Alexandru Elisei <alexandru.elisei@....com>,
Suzuki K Poulose <suzuki.poulose@....com>,
Oliver Upton <oliver.upton@...ux.dev>,
Tom Rix <trix@...hat.com>, kvm@...r.kernel.org,
linux-arm-kernel@...ts.infradead.org, kvmarm@...ts.linux.dev,
kvmarm@...ts.cs.columbia.edu, linux-riscv@...ts.infradead.org,
llvm@...ts.linux.dev, linux-kernel@...r.kernel.org,
Ricardo Koller <ricarkol@...gle.com>,
Aaron Lewis <aaronlewis@...gle.com>,
Raghavendra Rao Ananta <rananta@...gle.com>
Subject: Re: [PATCH 06/14] KVM: selftests: Rename UNAME_M to ARCH_DIR, fill
explicitly for x86
On 12/13/22 01:16, Sean Christopherson wrote:
> -ifeq ($(ARCH),riscv)
> - UNAME_M := riscv
> +ifeq ($(ARCH),x86)
> + ARCH_DIR := x86_64
> +else ifeq ($(ARCH),arm64)
> + ARCH_DIR := aarch64
> +else ifeq ($(ARCH),s390)
> + ARCH_DIR := s390x
> +else ifeq ($(ARCH),riscv)
> + ARCH_DIR := riscv
> +else
> +$(error Unknown architecture '$(ARCH)')
> endif
$(error) would break compiling via tools/testing/selftests/Makefile, so
I am squashing this:
diff --git a/tools/testing/selftests/kvm/Makefile
b/tools/testing/selftests/kvm/Makefile
index d761a77c3a80..59f3eb53c932 100644
--- a/tools/testing/selftests/kvm/Makefile
+++ b/tools/testing/selftests/kvm/Makefile
@@ -13,10 +13,8 @@ else ifeq ($(ARCH),arm64)
ARCH_DIR := aarch64
else ifeq ($(ARCH),s390)
ARCH_DIR := s390x
-else ifeq ($(ARCH),riscv)
- ARCH_DIR := riscv
else
-$(error Unknown architecture '$(ARCH)')
+ ARCH_DIR := $(ARCH)
endif
LIBKVM += lib/assert.c
Then the aarch64 and s390x directories can be renamed---x86 too, but the
ifeq needs to stay (just changed to do x86_64->x86 instead of the other
way round).
Paolo
Powered by blists - more mailing lists