[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <6e727952-3ad0-fcc3-82f1-c465dcffd56f@intel.com>
Date: Thu, 29 Dec 2022 10:54:50 +0100
From: Andrzej Hajda <andrzej.hajda@...el.com>
To: Andrew Morton <akpm@...ux-foundation.org>
Cc: linux-alpha@...r.kernel.org, linux-kernel@...r.kernel.org,
linux-snps-arc@...ts.infradead.org,
linux-arm-kernel@...ts.infradead.org,
linux-hexagon@...r.kernel.org, linux-ia64@...r.kernel.org,
loongarch@...ts.linux.dev, linux-m68k@...r.kernel.org,
linux-mips@...r.kernel.org, openrisc@...ts.librecores.org,
linux-parisc@...r.kernel.org, linuxppc-dev@...ts.ozlabs.org,
linux-riscv@...ts.infradead.org, linux-s390@...r.kernel.org,
linux-sh@...r.kernel.org, sparclinux@...r.kernel.org,
linux-xtensa@...ux-xtensa.org, intel-gfx@...ts.freedesktop.org,
dri-devel@...ts.freedesktop.org, Arnd Bergmann <arnd@...db.de>,
Rodrigo Vivi <rodrigo.vivi@...el.com>,
Andy Shevchenko <andriy.shevchenko@...ux.intel.com>,
Peter Zijlstra <peterz@...radead.org>,
Boqun Feng <boqun.feng@...il.com>,
Mark Rutland <mark.rutland@....com>
Subject: Re: [PATCH 00/19] Introduce __xchg, non-atomic xchg
Forgive me late response - Holidays,
On 22.12.2022 18:21, Andrew Morton wrote:
> On Thu, 22 Dec 2022 12:46:16 +0100 Andrzej Hajda <andrzej.hajda@...el.com> wrote:
>
>> Hi all,
>>
>> I hope there will be place for such tiny helper in kernel.
>> Quick cocci analyze shows there is probably few thousands places
>> where it could be useful.
> So to clarify, the intent here is a simple readability cleanup for
> existing open-coded exchange operations.
And replace private helpers with common one, see the last patch - the
ultimate goal
would be to replace all occurrences of fetch_and_zero with __xchg.
> The intent is *not* to
> identify existing xchg() sites which are unnecessarily atomic and to
> optimize them by using the non-atomic version.
>
> Have you considered the latter?
If you mean some way of (semi-)automatic detection of such cases, then
no. Anyway this could be quite interesting challenge.
>
>> I am not sure who is good person to review/ack such patches,
> I can take 'em.
>
>> so I've used my intuition to construct to/cc lists, sorry for mistakes.
>> This is the 2nd approach of the same idea, with comments addressed[0].
>>
>> The helper is tiny and there are advices we can leave without it, so
>> I want to present few arguments why it would be good to have it:
>>
>> 1. Code readability/simplification/number of lines:
>>
>> Real example from drivers/net/ethernet/mellanox/mlx5/core/esw/qos.c:
>> - previous_min_rate = evport->qos.min_rate;
>> - evport->qos.min_rate = min_rate;
>> + previous_min_rate = __xchg(evport->qos.min_rate, min_rate);
>>
>> For sure the code is more compact, and IMHO more readable.
>>
>> 2. Presence of similar helpers in other somehow related languages/libs:
>>
>> a) Rust[1]: 'replace' from std::mem module, there is also 'take'
>> helper (__xchg(&x, 0)), which is the same as private helper in
>> i915 - fetch_and_zero, see latest patch.
>> b) C++ [2]: 'exchange' from utility header.
>>
>> If the idea is OK there are still 2 qestions to answer:
>>
>> 1. Name of the helper, __xchg follows kernel conventions,
>> but for me Rust names are also OK.
> I like replace(), or, shockingly, exchange().
>
> But... Can we simply make swap() return the previous value?
>
> previous_min_rate = swap(&evport->qos.min_rate, min_rate);
As Alexander already pointed out, swap requires 'references' to two
variables,
in contrast to xchg which requires reference to variable and value.
So we cannot use swap for cases:
old_value = __xchg(&x, new_value);
Regards
Andrzej
Powered by blists - more mailing lists